Error code 403 with RUM agent

If you are asking about a problem you are experiencing, please use the following template, as it will help us help you. If you have a different problem, please delete all of this text :slight_smile:

Kibana version: 7.7

Elasticsearch version: 7.7

APM Server version: 7.7

APM Agent language and version: JavaScript (RUM) Version 5.1

Browser version: Chrome 80+

Original install method (e.g. download page, yum, deb, from source, etc.) and version: apt

Fresh install or upgraded from other version? recently updated from 7.4

Is there anything special in your setup? For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc.

Description of the problem including expected versus actual behavior. Please include screenshots (if relevant):
I am having trouble installing the RUM agent along the APM server (Version 7.7). I get an error code 403,
telling me that RUM is disabled (nothing else, including no complains about missing CORS headers), which is not the case (enabled: true).
The same error is present in the syslog and journalctl.
The application and the APM server run on different VMs, both use HTTPS. A Python agent
is already running in the backend and works fine. I have so far experimented with the
Access-Control-Allow-Origin header in the APM config, trying * and the actual origin, both lead to
a 403 status.

Steps to reproduce:
1.
2.
3.

Errors in browser console (if relevant): "forbidden request: RUM endpoint is disabled. Configure the apm-server.rum section in apm-server.yml"

Provide logs and/or server output (if relevant):

In the apm-server log, do you see "RUM endpoints disabled."? If you run apm-server export config, do you see something like the following in the output?

apm-server:
    host: localhost:8200
    rum:
        enabled: true
...

If it doesn't show up there, that would suggest there's a syntax issue in apm-server.yml.

That was indeed the problem! I disabled the Kibana section further down inside the config and also commented out the kibana at its beginning,so the enabled: false was associated with the rum section. Thank you!

1 Like