RUM Not reporting Data on Kibana


We have added the below options in the apm-server.rum section of the apm-server.yml config file to enable RUM Agent ,but its not reporting data back to the dashboard.

apm-server.rum.enabled: true
apm-server.auth.anonymous.rate_limit.event_limit: 300
apm-server.auth.anonymous.rate_limit.ip_limit: 1000
apm-server.auth.anonymous.allow_service: [your_service_name]
apm-server.rum.allow_origins: ['']
apm-server.rum.allow_headers: ["header1", "header2"]
apm-server.rum.library_pattern: "node_modules|bower_components|~"
apm-server.rum.exclude_from_grouping: "^/webpack"
apm-server.rum.source_mapping.enabled: true
apm-server.rum.source_mapping.cache.expiration: 5m
apm-server.rum.source_mapping.index_pattern: "apm-

Also added Install the RUM agent with HTML configuration in application HTML .
Please suggest which path need to be mention in below line

Pls suggest possible troubleshooting steps for the same.
We r running Kibana on Premise.

Hi @gauravraje, thanks for reaching out!

I have a couple of questions:

  • Which version of the Elastic Stack and rum agent are you running?

  • Are you seeing your web application sending events to the apm server?

In the fetch/xhr tab in the network tab of your browser devtools you should see something such as intake/v2/rum/events or intake/v3/rum/events. If so, what is the response status code?

On the other hand, in the configuration I'm seeing that the allow_origins configuration is empty, with the configuration set on this way the apm-server the browser is going to show up a CORS error.

The value of that configuration should contain the origin of your web (or webs). Let's image your website url is "", the value for the configuration should be apm-server.rum.allow_origins: ['']. More info about this here

When it comes to the HTML configuration you could use something such as:

<script src="https://<your-cdn-host>.com/path/to/elastic-apm-rum.umd.min-<version>.js" crossorigin></script>
    serviceName: '<instrumented-app>',
    serverUrl: '<apm-server-url>',

where <instrumented-app> is the value you have in apm-server.auth.anonymous.allow_service

and where <apm-server-url> is the value you should have in

More info about that here.


Have couple of questions,

  1. Do you see any errors on the console? If yes, can you also give us the debug logs by setting logLevel: debug in the agent configuration
  2. Do you mean Kibana dashboard? You can see RUM data on APM or User Experience application dashboard.


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.