Implement APM RUM into Kibana

If you are asking about a problem you are experiencing, please use the following template, as it will help us help you. If you have a different problem, please delete all of this text :slight_smile:

TIP 1: select at least one tag that further categorizes your topic. For example server for APM Server related questions, java for questions regarding the Elastic APM Java agent, or ui for questions about the APM App within Kibana.

TIP 2: Check out the troubleshooting guide first. Not only will it help you to resolve common problems faster but it also explains in more detail which information we need before we can properly help you.

Kibana version: 7.12.1

Elasticsearch version: 7.12.1

APM Server version: 7.12.1

APM Agent language and version: 5.x

Browser version: Chrome, Firefox, Edge, Safari

Original install method (e.g. download page, yum, deb, from source, etc.) and version: NA

Fresh install or upgraded from other version? NA

Is there anything special in your setup? For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc.
Response: We are using HAProxy as Load Balancer in front of the APM servers. But we don't change anything relate to index pattern, or anything else.

Description of the problem including expected versus actual behavior. Please include screenshots (if relevant): NA

Steps to reproduce: NA

Errors in browser console (if relevant): NA

Provide logs and/or server output (if relevant): NA

We want to know if possible put enable APM RUM for Kibana. This is for check User Experience for all persons are using Kibana. Purpose is want to know APDEX as KPI.


Perhaps Debugging Kibana | Kibana Guide [7.15] | Elastic describes what you want.

I am not sure it will cover your use case because I know the server-side APM integration in Kibana better, and not the RUM (client-side) APM.


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.