APM Server accepting events from RUM agent but not sending data to ES [Elastic Cloud]

Kibana version:
7.2.0
Elasticsearch version:
7.2.0
APM Server version:
7.2.0
APM Agent language and version:
Javascript APM-Rum 4.3.0
Browser version:
Google Chrome 75.0.3770.100
Original install method (e.g. download page, yum, deb, from source, etc.) and version:
Elastic Cloud
Fresh install or upgraded from other version?
Fresh install
Is there anything special in your setup? For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc.
APM Configuration changed on Elastic Cloud with:

apm-server.rum.enabled: true
apm-server.rum.allow_origins: '*'

Steps to reproduce:

  1. Create events in frontend
  2. Inspect HTTP request to APM RUM endpoint
  3. Responds with 202 Accepted
  4. No data/index in ES created

Provide logs and/or server output (if relevant):
Can't get APM logs from Elastic Cloud

1 Like

I have the same problem m8, I hope someone knows a solution

Do you mind opening an issue at https://cloud.elastic.co/help?

Hi Folks and thanks for trying Elastic APM

I just setup an Elasticsearch 7.2 Cluster in Elastic Cloud with APM. I did not alter any settings (which you should not have to because RUM is enabled by default in the Elastic Cloud APM server). Then I built and ran a React App and the RUM agent is reporting in fine.

I suspect you may not have loaded the Kibana Objects for APM.

You will need to navigate to the Kibana Home (top Left "K") the Add Data , APM and click on RUM (JS)

If you scroll to the bottom of that page there is a Load Kibana Objects and please click that. That loads the APM index pattern if you do not do that the data will not show up in the APM UI. (Note: technically the APM index pattern is used for all APM data)

Hopefully you should see the RUM Transactions now show up in the APM App like this. In my case car-front-end is the React App with RUM

Also you can check by go to the Dev Tools and run

GET _cat/indices

And you should get something like this, those are the APM indices

green open apm-7.2.0-span-2019.07.18        ntiCFchSSHODIrZKXBk5Rw 1 0 423 0 190.2kb 190.2kb
green open apm-7.2.0-metric-2019.07.18      zzm0uC9ZTXmoT4R4gdwQVA 1 0 195 0 182.2kb 182.2kb
green open apm-7.2.0-onboarding-2019.07.18  H8WwT8JOQGa47kBiMrT3qQ 1 0   1 0   6.2kb   6.2kb
green open apm-7.2.0-transaction-2019.07.18 30W2BaaoQN2OmE-Kw5-7Mw 1 0  21 0 217.3kb 217.3kb
green open .kibana_task_manager             jdCIInUvToeQ8SFSbTXjkQ 1 0   2 0  45.5kb  45.5kb
green open .kibana_1                        w3TPTvPAQx6AS9JfoQddrg 1 0   6 0  51.1kb  51.1kb
green open .security-7                      Xh4hSIIDShK07nfrekZE4Q 1 0  38 0 105.1kb 105.1kb

Let us know if that works!

Hi @stephenb, I did add the APM objects, however the problem is that no APM indices are getting created at all. When I run a local APM that is connected to Elastic Cloud everything seems to work fine.

We also have a kubernetes-metricbeat reporting to Elastic which does seems to be able to create indices just fine.

I've tried to delete the whole APM node in Elastic Cloud to re-create it, but it only lets me terminate and restart the node, not delete it completely (maybe some setting went wrong)?

@simitt, I have created an issue on that url.

Thank you for your response.

@stephenb @simitt We've re-created the deployment on Elastic Cloud since we weren't in a production ready state yet and everything seems to working fine now.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.