Error during make update while creating custom filebeat module

Trying to create a custom module for filebeat. I passed successfully the make create-module, make create-fileset, create and test the pipeline, make create-fields.
When running make update I get the following

mage update
Generated fields.yml for filebeat to /root/go/src/
Generated fields.yml for filebeat to /root/go/src/
>> Building filebeat.yml for linux/amd64
>> Building filebeat.reference.yml for linux/amd64
>> Building filebeat.docker.yml for linux/amd64
Error: parsing modules.d/f5_custom.yml.disabled as YAML: yaml: unmarshal errors:
  line 6: cannot unmarshal !!map into string
make: *** [update] Error 1

the file f5_custom.yml.disabled is auto created and contains the following

# Module: f5_custom
# Docs:

- module: f5_custom
  # All logs
    enabled: true

    # Set custom paths for the log files. If left empty,
    # Filebeat will choose the paths depending on your OS.

How can I fix this if the offending file is created automatically?


Is this {fileset} key normal? Can you compare your file with beats/apache.yml.disabled at main · elastic/beats · GitHub?

It doesn't look normal. It should take the fileset that I used when I run the "make create-fileset". The thing is, I didn't create this file, it was created automatically. I tried to edit it and run the "make update" again. The file was overwritten with one that has the same content as shown above and the process failed with the same error.

I see, this must be a bug. Could you open a Github issue explaining this so as to file it properly and have the team working on it?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.