Error: Failed to decrypt report job data. Please re-generate this report. how? 5.6.4


(andy_zhou) #1

Error: Failed to decrypt report job data. Please re-generate this report.

how to do about it ?

the other error.

Unhandled rejection Error: You must install fontconfig and freetype for Reporting to work


(Chris Roberson) #2

Hi @zqc0512,

Are you on Linux? The docs indicate that Linux users need to install a couple of packages (libfontconfig and libfreetype6) for reporting to work properly.

Thanks,
Chris


(andy_zhou) #3

thanks
in centos 7 is fontconfig and freetype use yum install
install it
it out put the other error.
Error: Timeout exceeded (20000)


(andy_zhou) #4

install it output the other error..

Error: Failed to decrypt report job data. Please re-generate this report.
also set
xpack.reporting.encryptionKey: "12345678"


(andy_zhou) #5

i will test it now .
the error is about have many kibana with the elasticsearch .
i shutdown the other kibana and left one .
as i test as i can.


(Chris Roberson) #6

K I'm not really sure what's going on. Did you successfully install those libraries (fontconfig and freetype) on your system?


(andy_zhou) #7

yes install it
see:

[root@xxx ~]# rpm -qa | grep freetype 
freetype-2.4.11-12.el7.x86_64
[root@xxxx ~]# rpm -qa | grep fontconfig
fontconfig-2.10.95-10.el7.x86_64

(Chris Roberson) #8

@zqc0512

Thanks, can you paste the entire error you're seeing after you installed those libraries?


(andy_zhou) #9

install no error

now it output the other error.

Max attempts reached (3)

There was an error generating your report for the "apache" dashboard: Max attempts reached (3)

i use logstash with this configure https://github.com/elastic/examples/blob/master/Common%20Data%20Formats/apache_logs/logstash/apache_logstash.conf

have a question about reporting :slight_smile:
if the reporting have a map. the kibana server need connect to es maps services with network or it use the local maps ? i can't reporting it output Max attempts reached (3)


(andy_zhou) #10

see the phantomjis

ps -ef | grep phantomjs
es         2751   2490  1 10:00 pts/0    00:00:00 /opt/kibana-5.6.4-linux-x86_64/data/phantomjs-2.1.1-linux-x86_64/bin/phantomjs **--load-images=true** --ssl-protocol=any --ignore-ssl-errors=true /opt/kibana-5.6.4-linux-x86_64/plugins/x-pack/node_modules/@elastic/node-phantom-simple/bridge.js 127.0.0.1 33228

--load-images=true have this . can any configure change it to false?


(Brandon Kobel) #11

Hey @zqc0512, do you have multiple Kibana instances pointed at the same Elasticsearch cluster? When using Reporting in this setting, all Kibana servers form a Reporting "cluster" and will take turns processing the Reporting jobs, which requires that the xpack.reporting.encryptionKey be set to the same value in all Kibana instance's kibana.yml.


(system) #12

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.