Error "fatal: Not a git repository (or any of the parent directories): .git" when trying to install a plugin in offline mode with LS 1.5.5 or newer


#1

Starting with Logstash 1.5.5 I get the following error message when trying to install with a downloaded gem file.

Validating /tmp/logstash-input-salesforce-0.1.1.gem
Installing logstash-input-salesforce
fatal: Not a git repository (or any of the parent directories): .git

I also tested with Logstash 1.5.6 and with different plugins but it is always the same error. With LS 1.5.4 everything works without problems.

It seems that now the gem spec file is now handled differently. Does somebody else has this problem and is there a way to fix it?


(system) #2