Error fetching data for metricset beat.state: error making http request: Get "https://xxx.xxxx.cloudapp.azure.com:5066/state": dial tcp connect: connection refused

Hi,
I'm Build remote monitoring cluster elastic stack to monitor elastic production environment.
I'm install metricbeats on the target and success to configure Elasticsearch-xpack and kibana-xpack, and I see metrics on monitoring cluster.
but when I try to configure beat-xpack module I get error :

ERROR module/wrapper.go:259 Error fetching data for metricset beat.stats: error making http request: Get "https://xxx.xxxx.cloudapp.azure.com:5066/stats": dial tcp 137.116.201.167:5066: connect: connection refused

the module file beat-xpack.yml looks like this :

  • module: beat
    xpack.enabled: true
    metricsets:

What I'm missing ?

Thank's for your help....

Hi!

Have you enabled Beat's monitoring port?

Hi,

What do you mean ? need to add port parameter to beat-xpack.yml ?

I see in your config that http.enabled: true is on module's level but I guess this should on top level of Metricbeat's config.

See more info at Use Metricbeat to send monitoring data | Metricbeat Reference [7.16] | Elastic.

The error you are hitting indicates that the monitoring endpoint is not reachable.

Hi,
I add http.enabled: true. and work as reference you send.

add this lines to metricbeats.yml :
monitoring.enabled: false
http.enabled: true
http.port: 5067
monitoring.cluster_uuid: "5p4sQBp2SjO2TOI5lPGigw"

beat-xpack.yml :

  • module: beat
    xpack.enabled: true
    metricsets:
    • stats
    • state
      period: 10s
      hosts: ["https://xxx.xxxx.xxx.xxx.com:5067"]
      username: "remote_monitoring_user"
      password: "xxxxxxxxxxx"
      ssl.verification: "none"
      http.enabled: true
      http.host: "xxx.xxx.xxx.xxx.xxx"
      http.port: 5067

still get the same error , please, what am I missing, ?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.