Error Importing csv files using logstash

Hey Guys,

I have been struggling to get through this issue from past one week.
Trying to upload a sample csv file using logstash and keep getting error, digged up in lot many documents and places and still didnt get any solution.

cmd i used : /usr/share/logstash/bin/logstash -f sample.config
OUTPUT: Sending Logstash's logs to /var/log/logstash which is now configured via
Elasticsearch Unreachable: [http://localhost:9200/][Manticore::SocketException] Connection refused (Connection refused)
No Available connections

Got these from /var/logs/logstash/logstash-plain.log

[ERROR][logstash.licensechecker.licensemanager] Unable to retrieve license information from license server {:message=>"Elasticsearch Unreachable: [http://logstash_system:xxxxxx@localhost:9200/][Manticore::SocketException] Connection refused (Connection refused)", :class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError"}

Have anybody faced this type of issue before, requesting your help.


Hi @Gauti,

Could you verify if elasticsearch is up? You can identify in elasticsearch logs or can try send telnet command "telnet localhost 9200".

I think that there is other logstash config file trying to connect with elasticsearch in this url [http://logstash_system:xxxxxx@localhost:9200/]. Check if you have another config file in /logstash/conf.d/.

hi @camarar

I had some issue connecting with localhost, now the issue is resolved and i'm able to telnet the localhost with port 9200

had tried running the csv upload command now and got the error
[FATAL][logstash.runner ] Logstash could not be started because there is already another instance using the configured data directory. If you wish to run multiple instances, you must change the "" setting.

I have logstash service running already.

cmd i tried : /usr/share/logstash -f test.config

Also logstash/conf.d directory is empty.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.