Error in 5.0.0-alpha5


(Brad Birdwell) #1

I have a elasticsearch cluster here at my office that I have been using to do various things trying to learn more about it. I decided I wanted to upgrade to the new version. At any rate now elasticsearch wont start. It throws the below error. Any help would be greatly appreciated.

[2016-09-16 10:08:12,537][INFO ][plugins ] [Elasticsearch-Alpha] loaded module [aggs-matrix-stats]
[2016-09-16 10:08:12,537][INFO ][plugins ] [Elasticsearch-Alpha] loaded module [ingest-common]
[2016-09-16 10:08:12,538][INFO ][plugins ] [Elasticsearch-Alpha] loaded module [lang-expression]
[2016-09-16 10:08:12,538][INFO ][plugins ] [Elasticsearch-Alpha] loaded module [lang-groovy]
[2016-09-16 10:08:12,538][INFO ][plugins ] [Elasticsearch-Alpha] loaded module [lang-mustache]
[2016-09-16 10:08:12,538][INFO ][plugins ] [Elasticsearch-Alpha] loaded module [lang-painless]
[2016-09-16 10:08:12,538][INFO ][plugins ] [Elasticsearch-Alpha] loaded module [percolator]
[2016-09-16 10:08:12,538][INFO ][plugins ] [Elasticsearch-Alpha] loaded module [reindex]
[2016-09-16 10:08:12,538][INFO ][plugins ] [Elasticsearch-Alpha] loaded module [transport-netty3]
[2016-09-16 10:08:12,538][INFO ][plugins ] [Elasticsearch-Alpha] loaded module [transport-netty4]
[2016-09-16 10:08:12,539][INFO ][plugins ] [Elasticsearch-Alpha] no plugins loaded
[2016-09-16 10:08:13,828][ERROR][bootstrap ] Exception
java.lang.IllegalArgumentException: unknown setting [bootstrap.mlockall] please check that any required plugins are installed, or check the breaking changes documentation for removed settings
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:270)
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:238)
at org.elasticsearch.common.settings.SettingsModule.(SettingsModule.java:138)
at org.elasticsearch.node.Node.(Node.java:298)
at org.elasticsearch.node.Node.(Node.java:206)
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:175)
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:175)
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:255)
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:101)
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:96)
at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54)
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:88)
at org.elasticsearch.cli.Command.main(Command.java:54)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:75)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:68)
[2016-09-16 10:08:13,833][WARN ][bootstrap ] [Elasticsearch-Alpha] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupError: java.lang.IllegalArgumentException: unknown setting [bootstrap.mlockall] please check that any required plugins are installed, or check the breaking changes documentation for removed settings
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:105)
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:96)
at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54)
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:88)
at org.elasticsearch.cli.Command.main(Command.java:54)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:75)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:68)
Caused by: java.lang.IllegalArgumentException: unknown setting [bootstrap.mlockall] please check that any required plugins are installed, or check the breaking changes documentation for removed settings
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:270)
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:238)
at org.elasticsearch.common.settings.SettingsModule.(SettingsModule.java:138)
at org.elasticsearch.node.Node.(Node.java:298)
at org.elasticsearch.node.Node.(Node.java:206)
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:175)
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:175)
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:255)
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:101)
... 6 more


(David Pilato) #2

Please format your code using </> icon. It will make your post more readable.

bootstrap.mlockall is not an available setting anymore. Check the breaking changes for 5.0.


(system) #3