Error in elastic search apm during performance testing

Hello i installed an APM in one of my machine and started a spring boot app with apm jar to send the metrics, i am receving the data from the app correctly but when we do performance testing on the app with 1000 requests per minute my apm server is throwing below ERROR in the log file and data is not getting ingested to elasticsearch. This is only happening while doin gperformance testing do i need to change any settings in my config to handle the heavy load.

ERROR [request] beater/handlers.go:384 error handling request {"request_id": "6cca8ddc-4d67-4b12-bdc9-6ff49ec3d263", "error": "while decoding: unexpected EOF"}

Hi and thanks for trying out Elastic APM!

Are you using the Java agent? The version 0.6.0 contains a bug which only occurs when the application is under some stress. I’ll release a bug fix ASAP. In the mean time, you can try a current snapshot:

Yes i am using the java agent version 0.6.0

Hi Felix is there any expected date when this bug is going to be fixed in the new version

Did the snapshot work for you? I’ll release a bug fix this week.

This is a direct link to the snapshot:

I have released 0.6.1 with a fix for this

@felixbarny this fix solved the problem thanks

1 Like

Hi Felix,

I have the same problem, but in my case with normal usage, not under heavy load.

It occurs when the payload has more than 1 element,

2018-08-27 12:47:40.587 [apm-reporter] DEBUG - Sending payload with 1 elements to APM server
2018-08-27 12:47:40.591 [apm-reporter] DEBUG - APM server responded with status code 202

2018-08-27 12:48:53.587 [apm-reporter] DEBUG - Sending payload with 8 elements to APM server
2018-08-27 12:48:53.590 [apm-reporter] DEBUG - APM server responded with status code 400
2018-08-27 12:48:53.591 [apm-reporter] DEBUG - data decoding error: unexpected EOF

I tried with versions
and the snapshot

with no luck.

I'm using apm-server version 6.3.2

Log in server side
2018-08-27T12:27:26.179+0200 ERROR [request] beater/handlers.go:414 error handling request {"request_id": "34a774a7-b5f7-4b64-bbd6-4bd9b6336e28", "method": "POST", "URL": "/v1/transactions", "content_length": -1, "remote_address": "", "user-agent": "apm-agent-java unknown", "response_code": 400, "error": "data decoding error: unexpected EOF"}

Any help would be appreciated! :slight_smile:

Thanks in advance,

Hi again,

Forget it. Value of jar to be loaded was not properly changed, and the same jar (0.6.0) was used in all cases.

It's working now with version 0.6.2.


1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.