Error in elastic search cluster

Hi,

I'm using the elastic search cluster .20.6 with following plugin installed
[mapper-attachments, jdbc-river, river-fs], sites [bigdesk, segmentspy,
head]. I'm able to create the index in cluster with following curl command

curl -XPUT 'http://localhost:9200/mydocs/ -d '{}' and replies

with {"ok":true,"acknowledged":true}

when i try to set the index properties with following command

curl -XPUT 'localhost:9200/_river/mydocs/_meta' -d '{ "type": "fs", "fs": { "name": "My tmp dir", "url": "/tmp", "update_rate": 900000, "includes": ".doc,.pdf", "excludes": "resume" }}'

in response, it return {"ok":true,"_index":"_river","_type":"mydocs
","_id":"_meta","_version":1}

in elastic search cluster, it don't index the following path and getting
following error:

Exception in thread "elasticsearch[searchnode][fs_slurper][T#1]"

java.lang.NoSuchMethodError:
org.elasticsearch.action.get.GetResponse.getSourceAsMap()Ljava/util/Map;

at

org.elasticsearch.river.fs.FsRiver$FSParser.getLastDateFromRiver(FsRiver.java:318)

at org.elasticsearch.river.fs.FsRiver$FSParser.run(FsRiver.java:278)

at java.lang.Thread.run(Unknown Source)

If elastic cluster is restated, it work fine and index the files, but same
error is coming every time on index settings.

thanks
Ajit

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi,

FSRiver 0.1.0 is not compatible with older version of ES.
See: https://github.com/dadoonet/fsriver

Update ES to 0.90.x or downgrade FS River to 0.0.3

HTH

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 27 mars 2013 à 13:04, Ajitpal Singh ajit.kamboj@gmail.com a écrit :

Hi,

I'm using the elastic search cluster .20.6 with following plugin installed [mapper-attachments, jdbc-river, river-fs], sites [bigdesk, segmentspy, head]. I'm able to create the index in cluster with following curl command

curl -XPUT 'http://localhost:9200/mydocs/ -d '{}' and replies with {"ok":true,"acknowledged":true}

when i try to set the index properties with following command

curl -XPUT 'localhost:9200/_river/mydocs/_meta' -d '{
"type": "fs",
"fs": {
"name": "My tmp dir",
"url": "/tmp",
"update_rate": 900000,
"includes": ".doc,.pdf",
"excludes": "resume"
}
}'
in response, it return {"ok":true,"_index":"_river","_type":"mydocs","_id":"_meta","_version":1}

in elastic search cluster, it don't index the following path and getting following error:

Exception in thread "elasticsearch[searchnode][fs_slurper][T#1]" java.lang.NoSuchMethodError: org.elasticsearch.action.get.GetResponse.getSourceAsMap()Ljava/util/Map;
at org.elasticsearch.river.fs.FsRiver$FSParser.getLastDateFromRiver(FsRiver.java:318)
at org.elasticsearch.river.fs.FsRiver$FSParser.run(FsRiver.java:278)
at java.lang.Thread.run(Unknown Source)

If elastic cluster is restated, it work fine and index the files, but same error is coming every time on index settings.

thanks
Ajit

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Thanks for reply :} . I'm using elastic search 0.20.6 latest sable release
with fsriver 0.1.0 plugin only.

Can fsriver plugin index remote directory or any other way around it?

Cheers!

On Wednesday, 27 March 2013 13:22:48 UTC, David Pilato wrote:

Hi,

FSRiver 0.1.0 is not compatible with older version of ES.
See: https://github.com/dadoonet/fsriver

Update ES to 0.90.x or downgrade FS River to 0.0.3

HTH

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 27 mars 2013 à 13:04, Ajitpal Singh <ajit....@gmail.com <javascript:>>
a écrit :

Hi,

I'm using the elastic search cluster .20.6 with following plugin installed
[mapper-attachments, jdbc-river, river-fs], sites [bigdesk, segmentspy,
head]. I'm able to create the index in cluster with following curl command

curl -XPUT 'http://localhost:9200/mydocs/ -d '{}' and replies

with {"ok":true,"acknowledged":true}

when i try to set the index properties with following command

curl -XPUT 'localhost:9200/_river/mydocs/_meta' -d '{ "type": "fs", "fs": { "name": "My tmp dir", "url": "/tmp", "update_rate": 900000, "includes": ".doc,.pdf", "excludes": "resume" }}'

in response, it return {"ok":true,"_index":"_river","_type":"mydocs
","_id":"_meta","_version":1}

in elastic search cluster, it don't index the following path and getting
following error:

Exception in thread "elasticsearch[searchnode][fs_slurper][T#1]"

java.lang.NoSuchMethodError:
org.elasticsearch.action.get.GetResponse.getSourceAsMap()Ljava/util/Map;

at

org.elasticsearch.river.fs.FsRiver$FSParser.getLastDateFromRiver(FsRiver.java:318)

at org.elasticsearch.river.fs.FsRiver$FSParser.run(FsRiver.java:278)

at java.lang.Thread.run(Unknown Source)

If elastic cluster is restated, it work fine and index the files, but same
error is coming every time on index settings.

thanks
Ajit

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

No. You have to mount your remote dir on your machine (NFS…).

What kind of remote dir do you want to index?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 27 mars 2013 à 14:49, Ajitpal Singh ajit.kamboj@gmail.com a écrit :

Thanks for reply :} . I'm using elastic search 0.20.6 latest sable release with fsriver 0.1.0 plugin only.

Can fsriver plugin index remote directory or any other way around it?

Cheers!

On Wednesday, 27 March 2013 13:22:48 UTC, David Pilato wrote:
Hi,

FSRiver 0.1.0 is not compatible with older version of ES.
See: https://github.com/dadoonet/fsriver

Update ES to 0.90.x or downgrade FS River to 0.0.3

HTH

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 27 mars 2013 à 13:04, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

I'm using the elastic search cluster .20.6 with following plugin installed [mapper-attachments, jdbc-river, river-fs], sites [bigdesk, segmentspy, head]. I'm able to create the index in cluster with following curl command

curl -XPUT 'http://localhost:9200/mydocs/ -d '{}' and replies with {"ok":true,"acknowledged":true}

when i try to set the index properties with following command

curl -XPUT 'localhost:9200/_river/mydocs/_meta' -d '{
"type": "fs",
"fs": {
"name": "My tmp dir",
"url": "/tmp",
"update_rate": 900000,
"includes": ".doc,.pdf",
"excludes": "resume"
}
}'
in response, it return {"ok":true,"_index":"_river","_type":"mydocs","_id":"_meta","_version":1}

in elastic search cluster, it don't index the following path and getting following error:

Exception in thread "elasticsearch[searchnode][fs_slurper][T#1]" java.lang.NoSuchMethodError: org.elasticsearch.action.get.GetResponse.getSourceAsMap()Ljava/util/Map;
at org.elasticsearch.river.fs.FsRiver$FSParser.getLastDateFromRiver(FsRiver.java:318)
at org.elasticsearch.river.fs.FsRiver$FSParser.run(FsRiver.java:278)
at java.lang.Thread.run(Unknown Source)

If elastic cluster is restated, it work fine and index the files, but same error is coming every time on index settings.

thanks
Ajit

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

I want to index both windows and ubuntu folders.
Cheers!

On Wednesday, 27 March 2013 14:26:49 UTC, David Pilato wrote:

No. You have to mount your remote dir on your machine (NFS…).

What kind of remote dir do you want to index?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 27 mars 2013 à 14:49, Ajitpal Singh <ajit....@gmail.com <javascript:>>
a écrit :

Thanks for reply :} . I'm using elastic search 0.20.6 latest sable release
with fsriver 0.1.0 plugin only.

Can fsriver plugin index remote directory or any other way around it?

Cheers!

On Wednesday, 27 March 2013 13:22:48 UTC, David Pilato wrote:

Hi,

FSRiver 0.1.0 is not compatible with older version of ES.
See: https://github.com/dadoonet/fsriver

Update ES to 0.90.x or downgrade FS River to 0.0.3

HTH

David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 27 mars 2013 à 13:04, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

I'm using the elastic search cluster .20.6 with following plugin
installed [mapper-attachments, jdbc-river, river-fs], sites [bigdesk,
segmentspy, head]. I'm able to create the index in cluster with following
curl command

curl -XPUT 'http://localhost:9200/mydocs/ -d '{}' and replies

with {"ok":true,"acknowledged":true}

when i try to set the index properties with following command

curl -XPUT 'localhost:9200/_river/mydocs/_meta' -d '{ "type": "fs", "fs": { "name": "My tmp dir", "url": "/tmp", "update_rate": 900000, "includes": ".doc,.pdf", "excludes": "resume" }}'

in response, it return {"ok":true,"_index":"_river","_type":"mydocs
","_id":"_meta","_version":1}

in elastic search cluster, it don't index the following path and getting
following error:

Exception in thread "elasticsearch[searchnode][fs_slurper][T#1]"

java.lang.NoSuchMethodError:
org.elasticsearch.action.get.GetResponse.getSourceAsMap()Ljava/util/Map;

at

org.elasticsearch.river.fs.FsRiver$FSParser.getLastDateFromRiver(FsRiver.java:318)

at org.elasticsearch.river.fs.FsRiver$FSParser.run(FsRiver.java:278)

at java.lang.Thread.run(Unknown Source)

If elastic cluster is restated, it work fine and index the files, but
same error is coming every time on index settings.

thanks
Ajit

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Using?
FTP, NFS, ... ?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 27 mars 2013 à 16:33, Ajitpal Singh ajit.kamboj@gmail.com a écrit :

I want to index both windows and ubuntu folders.
Cheers!

On Wednesday, 27 March 2013 14:26:49 UTC, David Pilato wrote:

No. You have to mount your remote dir on your machine (NFS…).

What kind of remote dir do you want to index?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 27 mars 2013 à 14:49, Ajitpal Singh ajit....@gmail.com a écrit :

Thanks for reply :} . I'm using elastic search 0.20.6 latest sable release with fsriver 0.1.0 plugin only.

Can fsriver plugin index remote directory or any other way around it?

Cheers!

On Wednesday, 27 March 2013 13:22:48 UTC, David Pilato wrote:

Hi,

FSRiver 0.1.0 is not compatible with older version of ES.
See: https://github.com/dadoonet/fsriver

Update ES to 0.90.x or downgrade FS River to 0.0.3

HTH

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 27 mars 2013 à 13:04, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

I'm using the elastic search cluster .20.6 with following plugin installed [mapper-attachments, jdbc-river, river-fs], sites [bigdesk, segmentspy, head]. I'm able to create the index in cluster with following curl command

curl -XPUT 'http://localhost:9200/mydocs/ -d '{}' and replies with {"ok":true,"acknowledged":true}

when i try to set the index properties with following command

curl -XPUT 'localhost:9200/_river/mydocs/_meta' -d '{
"type": "fs",
"fs": {
"name": "My tmp dir",
"url": "/tmp",
"update_rate": 900000,
"includes": ".doc,.pdf",
"excludes": "resume"
}
}'
in response, it return {"ok":true,"_index":"_river","_type":"mydocs","_id":"_meta","_version":1}

in elastic search cluster, it don't index the following path and getting following error:

Exception in thread "elasticsearch[searchnode][fs_slurper][T#1]" java.lang.NoSuchMethodError: org.elasticsearch.action.get.GetResponse.getSourceAsMap()Ljava/util/Map;
at org.elasticsearch.river.fs.FsRiver$FSParser.getLastDateFromRiver(FsRiver.java:318)
at org.elasticsearch.river.fs.FsRiver$FSParser.run(FsRiver.java:278)
at java.lang.Thread.run(Unknown Source)

If elastic cluster is restated, it work fine and index the files, but same error is coming every time on index settings.

thanks
Ajit

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

oh... My mistake!! ssh for ubuntu and Samba for window if possible.

cheers!! :}

On Wednesday, 27 March 2013 16:42:55 UTC, David Pilato wrote:

Using?
FTP, NFS, ... ?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 27 mars 2013 à 16:33, Ajitpal Singh <ajit....@gmail.com <javascript:>>
a écrit :

I want to index both windows and ubuntu folders.
Cheers!

On Wednesday, 27 March 2013 14:26:49 UTC, David Pilato wrote:

No. You have to mount your remote dir on your machine (NFS…).

What kind of remote dir do you want to index?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 27 mars 2013 à 14:49, Ajitpal Singh ajit....@gmail.com a écrit :

Thanks for reply :} . I'm using elastic search 0.20.6 latest sable
release with fsriver 0.1.0 plugin only.

Can fsriver plugin index remote directory or any other way around it?

Cheers!

On Wednesday, 27 March 2013 13:22:48 UTC, David Pilato wrote:

Hi,

FSRiver 0.1.0 is not compatible with older version of ES.
See: https://github.com/dadoonet/fsriver

Update ES to 0.90.x or downgrade FS River to 0.0.3

HTH

David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 27 mars 2013 à 13:04, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

I'm using the elastic search cluster .20.6 with following plugin
installed [mapper-attachments, jdbc-river, river-fs], sites [bigdesk,
segmentspy, head]. I'm able to create the index in cluster with following
curl command

curl -XPUT 'http://localhost:9200/mydocs/ -d '{}' and replies

with {"ok":true,"acknowledged":true}

when i try to set the index properties with following command

curl -XPUT 'localhost:9200/_river/mydocs/_meta' -d '{ "type": "fs", "fs": { "name": "My tmp dir", "url": "/tmp", "update_rate": 900000, "includes": ".doc,.pdf", "excludes": "resume" }}'

in response, it return {"ok":true,"_index":"_river","_type":"mydocs
","_id":"_meta","_version":1}

in elastic search cluster, it don't index the following path and getting
following error:

Exception in thread "elasticsearch[searchnode][fs_slurper][T#1]"

java.lang.NoSuchMethodError:
org.elasticsearch.action.get.GetResponse.getSourceAsMap()Ljava/util/Map;

at

org.elasticsearch.river.fs.FsRiver$FSParser.getLastDateFromRiver(FsRiver.java:318)

at org.elasticsearch.river.fs.FsRiver$FSParser.run(FsRiver.java:278)

at java.lang.Thread.run(Unknown Source)

If elastic cluster is restated, it work fine and index the files, but
same error is coming every time on index settings.

thanks
Ajit

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

I think that you can mount samba, no ?
Ssh is not supported. Open an issue?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 27 mars 2013 à 17:51, Ajitpal Singh ajit.kamboj@gmail.com a écrit :

oh... My mistake!! ssh for ubuntu and Samba for window if possible.

cheers!! :}

On Wednesday, 27 March 2013 16:42:55 UTC, David Pilato wrote:

Using?
FTP, NFS, ... ?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 27 mars 2013 à 16:33, Ajitpal Singh ajit....@gmail.com a écrit :

I want to index both windows and ubuntu folders.
Cheers!

On Wednesday, 27 March 2013 14:26:49 UTC, David Pilato wrote:

No. You have to mount your remote dir on your machine (NFS…).

What kind of remote dir do you want to index?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 27 mars 2013 à 14:49, Ajitpal Singh ajit....@gmail.com a écrit :

Thanks for reply :} . I'm using elastic search 0.20.6 latest sable release with fsriver 0.1.0 plugin only.

Can fsriver plugin index remote directory or any other way around it?

Cheers!

On Wednesday, 27 March 2013 13:22:48 UTC, David Pilato wrote:

Hi,

FSRiver 0.1.0 is not compatible with older version of ES.
See: https://github.com/dadoonet/fsriver

Update ES to 0.90.x or downgrade FS River to 0.0.3

HTH

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 27 mars 2013 à 13:04, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

I'm using the elastic search cluster .20.6 with following plugin installed [mapper-attachments, jdbc-river, river-fs], sites [bigdesk, segmentspy, head]. I'm able to create the index in cluster with following curl command

curl -XPUT 'http://localhost:9200/mydocs/ -d '{}' and replies with {"ok":true,"acknowledged":true}

when i try to set the index properties with following command

curl -XPUT 'localhost:9200/_river/mydocs/_meta' -d '{
"type": "fs",
"fs": {
"name": "My tmp dir",
"url": "/tmp",
"update_rate": 900000,
"includes": ".doc,.pdf",
"excludes": "resume"
}
}'
in response, it return {"ok":true,"_index":"_river","_type":"mydocs","_id":"_meta","_version":1}

in elastic search cluster, it don't index the following path and getting following error:

Exception in thread "elasticsearch[searchnode][fs_slurper][T#1]" java.lang.NoSuchMethodError: org.elasticsearch.action.get.GetResponse.getSourceAsMap()Ljava/util/Map;
at org.elasticsearch.river.fs.FsRiver$FSParser.getLastDateFromRiver(FsRiver.java:318)
at org.elasticsearch.river.fs.FsRiver$FSParser.run(FsRiver.java:278)
at java.lang.Thread.run(Unknown Source)

If elastic cluster is restated, it work fine and index the files, but same error is coming every time on index settings.

thanks
Ajit

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Thanks. I will open an issue for it.

I'm trying to search the file using elastic search, the CURL query is

http://localhost:9200/mydocs,myjdbc/_search?pretty&q=ajitpalshttp://192.168.81.128:9200/mydocs,myjdbc/_search?pretty&q=ajitpals

How can we limit or remove the content field in json result. Is the above
way to query is right?

Cheers!

On Wednesday, 27 March 2013 17:09:16 UTC, David Pilato wrote:

I think that you can mount samba, no ?
Ssh is not supported. Open an issue?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 27 mars 2013 à 17:51, Ajitpal Singh <ajit....@gmail.com <javascript:>>
a écrit :

oh... My mistake!! ssh for ubuntu and Samba for window if possible.

cheers!! :}

On Wednesday, 27 March 2013 16:42:55 UTC, David Pilato wrote:

Using?
FTP, NFS, ... ?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 27 mars 2013 à 16:33, Ajitpal Singh ajit....@gmail.com a écrit :

I want to index both windows and ubuntu folders.
Cheers!

On Wednesday, 27 March 2013 14:26:49 UTC, David Pilato wrote:

No. You have to mount your remote dir on your machine (NFS…).

What kind of remote dir do you want to index?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 27 mars 2013 à 14:49, Ajitpal Singh ajit....@gmail.com a écrit :

Thanks for reply :} . I'm using elastic search 0.20.6 latest sable
release with fsriver 0.1.0 plugin only.

Can fsriver plugin index remote directory or any other way around it?

Cheers!

On Wednesday, 27 March 2013 13:22:48 UTC, David Pilato wrote:

Hi,

FSRiver 0.1.0 is not compatible with older version of ES.
See: https://github.com/dadoonet/fsriver

Update ES to 0.90.x or downgrade FS River to 0.0.3

HTH

David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 27 mars 2013 à 13:04, Ajitpal Singh ajit....@gmail.com a écrit :

Hi,

I'm using the elastic search cluster .20.6 with following plugin
installed [mapper-attachments, jdbc-river, river-fs], sites [bigdesk,
segmentspy, head]. I'm able to create the index in cluster with following
curl command

curl -XPUT 'http://localhost:9200/mydocs/ -d '{}' and replies

with {"ok":true,"acknowledged":true}

when i try to set the index properties with following command

curl -XPUT 'localhost:9200/_river/mydocs/_meta' -d '{ "type": "fs", "fs": { "name": "My tmp dir", "url": "/tmp", "update_rate": 900000, "includes": ".doc,.pdf", "excludes": "resume" }}'

in response, it return {"ok":true,"_index":"_river","_type":"mydocs
","_id":"_meta","_version":1}

in elastic search cluster, it don't index the following path and
getting following error:

Exception in thread "elasticsearch[searchnode][fs_slurper][T#1]"

java.lang.NoSuchMethodError:
org.elasticsearch.action.get.GetResponse.getSourceAsMap()Ljava/util/Map;

at

org.elasticsearch.river.fs.FsRiver$FSParser.getLastDateFromRiver(FsRiver.java:318)

at org.elasticsearch.river.fs.FsRiver$FSParser.run(FsRiver.java:278)

at java.lang.Thread.run(Unknown Source)

If elastic cluster is restated, it work fine and index the files, but
same error is coming every time on index settings.

thanks
Ajit

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.