Error In Elasticsearch After enable security on Window

Hi Team,
I am getting below error while running elastic search after enable security :slight_smile:

2019-07-11T12:30:59,252][ERROR][o.e.b.Bootstrap ] [CMSDEV] node validation exception
[1] bootstrap checks failed
[1]: Transport SSL must be enabled if security is enabled on a [basic] license. Please set [xpack.security.transport.ssl.enabled] to [true] or disable security by setting [xpack.security.enabled] to [false]

below are the my elasticsearch yaml file configuration:

bootstrap.memory_lock: true
cluster.name: logging-dev
network.host: 0.0.0.0
network.bind_host: 0.0.0.0
network.publish_host: 0.0.0.0
http.port: 9200
node.data: true
node.ingest: true
node.master: true
node.max_local_storage_nodes: 3
node.name: CMSDEV
path.data: D:\ElasticStack\Elasticsearch\data
path.logs: D:\ElasticStack\Elasticsearch\logs
transport.tcp.port: 9300
xpack.license.self_generated.type: basic
xpack.security.enabled: true
cluster.initial_master_nodes: node-1

xpack.security.http.ssl.enabled: true
xpack.security.http.ssl.keystore.path: certs/elastic-certificates.p12 
xpack.security.http.ssl.truststore.path: certs/elastic-certificates.p12

check this post XPACK Security in ELK stack 7.1.1

Thanks for the reply.

I have followed all that security step after generated certificate.
While try to run elastic search. I am getting the above error.

Use this note, and change your elasticsearch.yml file

 discovery.type: single-node

Single-node discovery (https://github.com/elastic/elasticsearch/edit/7.2/docs/reference/setup/bootstrap-checks.asciidoc)

We recognize that some users need to bind transport to an external interface for testing their usage of the transport client. For this situation, we provide the discovery type single-node (configure it by setting discovery.type to single-node ); in this situation, a node will elect itself master and will not join a cluster with any other node.

Thanks @ylasri,

Its working now. I was missing this configuration.