Error in Elasticsearch After upgrading from 5.6 - 6.4


(Anam ) #1

After I upgrade ELK stack from 5.6 to 6.4 I am getting an error in Elasticsearch.

Dec 06 12:00:47 logstash-sf elasticsearch[24855]: at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:294)
Dec 06 12:00:47 logstash-sf elasticsearch[24855]: at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136)
Dec 06 12:00:47 logstash-sf elasticsearch[24855]: at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:127)
Dec 06 12:00:47 logstash-sf elasticsearch[24855]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)
Dec 06 12:00:47 logstash-sf elasticsearch[24855]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124)
Dec 06 12:00:47 logstash-sf elasticsearch[24855]: at org.elasticsearch.cli.Command.main(Command.java:90)
Dec 06 12:00:47 logstash-sf elasticsearch[24855]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93)
Dec 06 12:00:47 logstash-sf elasticsearch[24855]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:86)
Dec 06 12:00:47 logstash-sf elasticsearch[24855]: 2018-12-06 12:00:47,261 main ERROR Null object returned for RollingFile in Appenders.
Dec 06 12:00:47 logstash-sf elasticsearch[24855]: 2018-12-06 12:00:47,262 main ERROR Unable to locate appender "audit_rolling" for logger config "org.elasticsearch.xpack.security.audit.logfile.LoggingAudi

Please let me know to resolve this issue.