Error in installing logstash-plugin


(Sahar Q) #1

Command:
bin/logstash-plugin install logstash-codec-gzip_lines
ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "logstash-core-plugin-api":
In snapshot (Gemfile.lock):
logstash-core-plugin-api (= 2.1.12)

• Logstash Version 5.4
• Plugin attepted - gzip_lines
any explanation?


(pts0) #2

Hi,
we would like to held you, but you should provide some more details. Version, which plugin, did you have an internet connection ...
I Suppose your plugin is not compatible (wrong version). Or you miss connection to internet.

pts0


(Sahar Q) #3

Hi, i am using logstash version 5.4
and trying to install the "gzip_lines" plugin,
i do have an internet connection.


(pts0) #4

I don't know if it help you, but it seam to be broken,

I just try it out on my unix server (ubuntu linux) with 5.4.1.

wget https://artifacts.elastic.co/downloads/logstash/logstash-5.4.1.tar.gz

then

pts0@myservername:~/sandbox/logstash-5.4.1$ bin/logstash-plugin install logstash-codec-gzip_lines
Validating logstash-codec-gzip_lines
Installing logstash-codec-gzip_lines
Plugin version conflict, aborting
ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "logstash-core-plugin-api":
  In snapshot (Gemfile.lock):
    logstash-core-plugin-api (= 2.1.12)

  In Gemfile:
    logstash-devutils (>= 0) java depends on
      logstash-core-plugin-api (<= 2.99, >= 2.0) java

    logstash-input-s3 (>= 0) java depends on
      logstash-mixin-aws (>= 0) java depends on
        logstash-core-plugin-api (<= 2.99, >= 1.60) java

  ...

    logstash-codec-gzip_lines (>= 0) java depends on
      logstash-core-plugin-api (~> 1.0) java

    logstash-core-plugin-api (>= 0) java

Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
Bundler could not find compatible versions for gem "logstash-core":
  In snapshot (Gemfile.lock):
    logstash-core (= 5.4.1)

  In Gemfile:
    logstash-core-plugin-api (>= 0) java depends on
      logstash-core (= 5.4.1) java

    logstash-codec-gzip_lines (>= 0) java depends on
      logstash-core (< 2.0.0, >= 1.4.0) java

    logstash-core (>= 0) java

Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
Bundler could not find compatible versions for gem "logstash":
  In Gemfile:
    logstash-codec-gzip_lines (>= 0) java depends on
      logstash (< 2.0.0, >= 1.4.0) java
Could not find gem 'logstash (< 2.0.0, >= 1.4.0) java', which is required by gem 'logstash-codec-gzip_lines (>= 0) java', in any of the sources.

(Sahar Q) #5

yea, thats exactly the error i get :confused:


(pts0) #6

Disclaimer :

This is a community-maintained plugin! It does not ship with Logstash by default, but it is easy to install by running bin/logstash-plugin install logstash-codec-gzip_lines

Maybe contact maintainer ... and as far I can see in github is not tagged for any 5.x version

Suppose is not supported anymore


(Sahar Q) #7

do you know any replacements in order to recieve gzip data with logstash?
Edit: @pts0 thanks for your help so far !


(pts0) #8

Have a look what @ruflin write here https://stackoverflow.com/questions/34621685/use-filebeat-or-logstash-to-open-gzip-files is one year old ... but if you post on beat forum i m sure he will reply :wink:


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.