Installting Logstash Plugins


(Tahir) #1

Hi
I am trying to install logstash plugin and getting following error:

Installing logstash-codec-nmap
Plugin version conflict, aborting
ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "logstash-core-plugin-api":
In snapshot (Gemfile.lock):
logstash-core-plugin-api (= 2.1.16)

In Gemfile:
logstash-devutils (~> 1.1) java depends on
logstash-core-plugin-api (~> 2.0) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

.......
logstash-core (>= 0) java

Running bundle update will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.


(Tahir) #2

I am having exact same problem can someone help me with this. Unable to install plugins in logstash


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.