I just installed logstash from the latest tar.gz file 5.2.2 is the version number.
I have searched the forum and seen this eror come up a few time but no solution were proposed.
So I installed logstash and I need 2 plugin that are not buddled with it.
The syslog plugin installed just fine, but the zeromq one gives me an error.
Plugin version conflict, aborting ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "logstash-core": In snapshot (Gemfile.lock): logstash-core (= 5.2.2) In Gemfile: logstash-core-plugin-api (>= 0) java depends on logstash-core (= 5.2.2) java logstash-input-zeromq (>= 0) java depends on logstash-core (< 2.0.0, >= 1.4.0) java logstash-core (>= 0) java
Then list a truck load of plugin and their dependencies, but they are all fine, then it finishes up with pretty much the same thing.
Running `bundle update` will rebuild your snapshot from scratch, using only the gems in your Gemfile, which may resolve the conflict. Bundler could not find compatible versions for gem "logstash": In Gemfile: logstash-input-zeromq (>= 0) java depends on logstash (< 2.0.0, >= 1.4.0) java Could not find gem 'logstash (< 2.0.0, >= 1.4.0) java', which is required by gem 'logstash-input-zeromq (>= 0) java', in any of the sources.
It looks like its not compatible with logstash 5.2.2
Like its looking for logstash-core < 2.0.0 if im reading right.
Im not familiar with ruby and gems so I'm having a hard time figuring out how to fix this.
Can someone help?