Error Initiating elasticsearch after windows 10 install


(Felix Ivan Romero Rodríguez) #1

I 've installed elasticsearch 6.1 on windows 10 with Java 8 amd64. But can not run it. It throws the followin error:
WARNING: sun.reflect.Reflection.getCallerClass is not supported. This will impact performance.
[2018-02-06T05:47:48,524][INFO ][o.e.n.Node ] [FIROMERO] initializing ...
[2018-02-06T05:47:48,773][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [FIROMERO] fatal error in thread [main], exiting

java.lang.NoSuchMethodError: java.util.Base64$Encoder.withoutPadding()Ljava/util/Base64$Encoder;
at org.elasticsearch.common.RandomBasedUUIDGenerator.getBase64UUID(RandomBasedUUIDGenerator.java:58) ~[elasticsearch-6.1.1.jar:6.1.1]
at org.elasticsearch.common.UUIDs.randomBase64UUID(UUIDs.java:44) ~[elasticsearch-6.1.1.jar:6.1.1]
at org.elasticsearch.env.NodeEnvironment.generateNodeId(NodeEnvironment.java:369) ~[elasticsearch-6.1.1.jar:6.1.1]
at org.elasticsearch.env.NodeEnvironment.loadOrCreateNodeMetaData(NodeEnvironment.java:360) ~[elasticsearch-6.1.1.jar:6.1.1]
at org.elasticsearch.env.NodeEnvironment.(NodeEnvironment.java:246) ~[elasticsearch-6.1.1.jar:6.1.1]
at org.elasticsearch.node.Node.(Node.java:263) ~[elasticsearch-6.1.1.jar:6.1.1]
at org.elasticsearch.node.Node.(Node.java:245) ~[elasticsearch-6.1.1.jar:6.1.1]
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:212) ~[elasticsearch-6.1.1.jar:6.1.1]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:212) ~[elasticsearch-6.1.1.jar:6.1.1]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:322) ~[elasticsearch-6.1.1.jar:6.1.1]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121) ~[elasticsearch-6.1.1.jar:6.1.1]
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) ~[elasticsearch-6.1.1.jar:6.1.1]
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-6.1.1.jar:6.1.1]
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-6.1.1.jar:6.1.1]
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-6.1.1.jar:6.1.1]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-6.1.1.jar:6.1.1]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:85) ~[elasticsearch-6.1.1.jar:6.1.1]

I need some help to fix it. Thank you.
Best regards


(Felix Ivan Romero Rodríguez) #2

I have found the solution. The issue was an update missing from jdk 8.
best regards


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.