Error OPERATION_NOT_ALLOWED

We have a ELK-5.6.3 cluster with readonlyrest pro plugin and running fine. For some reasons we need to migrate to 7.6.2 as separate cluster. The new cluster also enabled with readonlyrest free and xpack disabled. When doing reindex from remote cluster, getting an error with below. When disable readonlyrest, remote reindex is working without any error. Can you help me how can we achieve it with readonlyrest enabled.

{
"error" : {
"root_cause" : [
{
"reason" : "Sorry, Forbidden Request by Elasticsearch.",
"due_to" : [
"OPERATION_NOT_ALLOWED"
]
}
],
"reason" : "Sorry, Forbidden Request by Elasticsearch.",
"due_to" : [
"OPERATION_NOT_ALLOWED"
],
"status" : 401
}
}

I think you should ask the authors of this project.

Why not using elasticsearch security built in feature?

Hi @dadoonet,

Thanks for your reply. readonlyreset is management decision as of legacy setup.

The issue solved now. I was not giving username.password while making above query. Specified the user name and password for server authentication that worked.