Error regarding logstash pipeline has been started but index is not being created


(pratibha) #1

C:\Users\pratiswa\Downloads\logstash-6.2.1\logstash-6.2.1\bin>logstash -f C:\Users\pratiswa\Desktop\logstash_nba.config
Sending Logstash's logs to C:/Users/pratiswa/Downloads/logstash-6.2.1/logstash-6.2.1/logs which is now configured via log4j2.properties
[2018-02-14T23:31:35,285][INFO ][logstash.modules.scaffold] Initializing module {:module_name=>"fb_apache", :directory=>"C:/Users/pratiswa/Downloads/logstash-6.2.1/logstash-6.2.1/modules/fb_apache/configuration"}
[2018-02-14T23:31:35,302][INFO ][logstash.modules.scaffold] Initializing module {:module_name=>"netflow", :directory=>"C:/Users/pratiswa/Downloads/logstash-6.2.1/logstash-6.2.1/modules/netflow/configuration"}
[2018-02-14T23:31:35,545][WARN ][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2018-02-14T23:31:36,000][INFO ][logstash.runner ] Starting Logstash {"logstash.version"=>"6.2.1"}
[2018-02-14T23:31:36,383][INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9600}
[2018-02-14T23:31:38,104][INFO ][logstash.pipeline ] Starting pipeline {:pipeline_id=>"main", "pipeline.workers"=>4, "pipeline.batch.size"=>125, "pipeline.batch.delay"=>5}
[2018-02-14T23:31:38,587][INFO ][logstash.outputs.elasticsearch] Elasticsearch pool URLs updated {:changes=>{:removed=>[], :added=>[http://localhost:9200/]}}
[2018-02-14T23:31:38,596][INFO ][logstash.outputs.elasticsearch] Running health check to see if an Elasticsearch connection is working {:healthcheck_url=>http://localhost:9200/, :path=>"/"}
[2018-02-14T23:31:38,782][WARN ][logstash.outputs.elasticsearch] Restored connection to ES instance {:url=>"http://localhost:9200/"}
[2018-02-14T23:31:38,840][INFO ][logstash.outputs.elasticsearch] ES Output version determined {:es_version=>nil}
[2018-02-14T23:31:38,845][WARN ][logstash.outputs.elasticsearch] Detected a 6.x and above cluster: the type event field won't be used to determine the document _type {:es_version=>6}
[2018-02-14T23:31:38,866][INFO ][logstash.outputs.elasticsearch] Using mapping template from {:path=>nil}
[2018-02-14T23:31:38,892][INFO ][logstash.outputs.elasticsearch] Attempting to install template {:manage_template=>{"template"=>"logstash-", "version"=>60001, "settings"=>{"index.refresh_interval"=>"5s"}, "mappings"=>{"default"=>{"dynamic_templates"=>[{"message_field"=>{"path_match"=>"message", "match_mapping_type"=>"string", "mapping"=>{"type"=>"text", "norms"=>false}}}, {"string_fields"=>{"match"=>"", "match_mapping_type"=>"string", "mapping"=>{"type"=>"text", "norms"=>false, "fields"=>{"keyword"=>{"type"=>"keyword", "ignore_above"=>256}}}}}], "properties"=>{"@timestamp"=>{"type"=>"date"}, "@version"=>{"type"=>"keyword"}, "geoip"=>{"dynamic"=>true, "properties"=>{"ip"=>{"type"=>"ip"}, "location"=>{"type"=>"geo_point"}, "latitude"=>{"type"=>"half_float"}, "longitude"=>{"type"=>"half_float"}}}}}}}}
[2018-02-14T23:31:38,939][INFO ][logstash.outputs.elasticsearch] New Elasticsearch output {:class=>"LogStash::Outputs::ElasticSearch", :hosts=>["//localhost:9200"]}
[2018-02-14T23:31:39,685][INFO ][logstash.pipeline ] Pipeline started succesfully {:pipeline_id=>"main", :thread=>"#<Thread:0x4f2f89 run>"}
[2018-02-14T23:31:39,781][INFO ][logstash.agent ] Pipelines running {:count=>1, :pipelines=>["main"]}

here is my config file

input{
file{
path => "C:\Users\pratiswa\Desktop\data\nba"
start_position => "beginning"
}
}
output{
elasticsearch{
hosts => "localhost:9200"
user => logstash_internal
}
}

pipeline has started but index is not being created


(Imran Ali) #2

I too have same messages in logstash-plain.log. When I run logstash manually I receive
[406] {"error":"Content-Type header [text/plain; charset=ISO-8859-1] is not supported","status":406} {:class=>"Elasticsearch::Transport::Transport::Errors::NotAcceptable", :level=>:error}

I have tried and reverted logstash to 2.x but still it does not resolve.
Request help


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.