Error Starting Logstash(Any version)


(James Giouroukelis) #1

I am trying to run Logstash on my machine (mac osx high sierra), but am encountering an error when i run ./bin/logstash

I get the error when trying the "hello world", and without any config file still gives this error which leads me to believe there is something wrong with my installation

The error is:
[ERROR] 2018-07-03 16:29:45.436 [main] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (LoadError) load error: jopenssl/load -- java.lang.IncompatibleClassChangeError: Implementing class

Ive tried redownloading logstash, reinstalling my jdk, which is:
(java -version
java version "1.8.0_171"
Java(TM) SE Runtime Environment (build 1.8.0_171-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.171-b11, mixed mode))

my JAVA_HOME should be correct in my bash profile
"export JAVA_HOME=$(/usr/libexec/java_home -v 1.8)"

so i really have no idea whats causing the problem
was wondering if anybody has a solution?


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.