Error trying reindex from remote host

Hi, dear Community of elastic I got this problem trying to reindex from a remote host of my production environment to my development one in the elastic cloud

It may the error caused by the different versions of the hosts?
I tried doing it by CURL in my terminal, same error in kibana as my console.
The index has the same mapping settings
I create the index prior run the code and both have the same mappings as I described above.

Production Environment: 6.3.0
Development Environment: 6.7.0

Please don't post images of text, they're impossible to search and they cannot be read by those of us using a screenreader.

The error looks like a rejected execution exception: the write queue capacity is only 200 tasks but the reindex tried to submit a batch containing 210 items all for the same shard. You can limit the size of batches by setting the source.size parameter.

Thank you very much for your help David, I'm sorry that won't happen again, I'm going to edit the post, btw I run the following command at dev tools:

    POST _reindex
  "source": {
    "size":  1000,
    "remote": {
      "host": "",
      "username": "enyer.q",
      "password": "Eny3rQ"
    "index": "social__instagram__messi"
  "dest": {
    "index": "social__instagram__messi__dev"

and I got the same error:`

          "took": 59633,
          "timed_out": false,
          "total": 1672,
          "updated": 0,
          "created": 0,
          "deleted": 0,
          "batches": 1,
          "version_conflicts": 0,
          "noops": 0,
          "retries": {
            "bulk": 11,
            "search": 0
          "throttled_millis": 0,
          "requests_per_second": -1,
          "throttled_until_millis": 0,
          "failures": [
              "index": "social__instagram__messi__dev",
              "type": "doc",
              "id": "WZTvymkBvul5dhct2pDE",
              "cause": {
                "type": "es_rejected_execution_exception",
                "reason": "rejected execution of processing of [2186383][indices:data/write/bulk[s][p]]: request: BulkShardRequest [[social__instagram__messi__dev][0]] containing [201] requests, target allocation id: 4Q2kkMncSSySilsOquJB9g, primary term: 1 on EsThreadPoolExecutor[name = instance-0000000019/write, queue capacity = 200, org.elasticsearch.common.util.concurrent.EsThreadPoolExecutor@455a5c64[Running, pool size = 2, active threads = 2, queued tasks = 200, completed tasks = 115574]]"
              "status": 429

It looks like you're still overflowing the write queue. There's only room in the queue for 200 tasks and you're asking for batches of 1000.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.