Error: 'tuple' object is not callable

Hello I run this

FROM python:3.6-alpine

COPY ./config /config

RUN pip install  elasticsearch-curator==5.8.0 &&\
    pip install elasticsearch==7.0.4 &&\
     rm -rf /var/cache/apk/*

CMD curator --config /config/config_file.yml /config/action_file.yml

And then I got this

2020-02-26 04:27:20,313 INFO                 curator.cli                    run:148  Preparing Action ID: 1, "snapshot"

2020-02-26 04:27:20,313 INFO                 curator.cli                    run:162  Creating client object and testing connection

2020-02-26 04:27:20,313 DEBUG              curator.utils             get_client:809  kwargs = {'hosts': ['elasticsearch'], 'port': 9200, 'use_ssl': False, 'ssl_no_validate': False, 'http_auth': "''", 'master_only': False, 'client_cert': None, 'aws_token': None, 'aws_key': None, 'certificate': None, 'aws_sign_request': False, 'aws_secret_key': None, 'client_key': None, 'url_prefix': '', 'timeout': 21600}

2020-02-26 04:27:20,313 DEBUG              curator.utils             get_client:871  Checking for AWS settings

2020-02-26 04:27:20,317 DEBUG              curator.utils             get_client:886  "requests_aws4auth" module present, but not used.

2020-02-26 04:27:20,317 INFO               curator.utils             get_client:903  Instantiating client object

2020-02-26 04:27:20,318 INFO               curator.utils             get_client:906  Testing client connectivity

2020-02-26 04:27:20,318 ERROR              curator.utils             get_client:919  Unable to connect to Elasticsearch cluster. Error: 'tuple' object is not callable

2020-02-26 04:27:20,318 CRITICAL           curator.utils             get_client:923  Curator cannot proceed. Exiting.

Also if I install curator from yum repository. I got taks_id missed error. Version curator 5.8.1 with elasticsearch-py 7.1.0 returns the same error. How can i solve this problem?

Hi. I have had the same problem. In my case the user / pwd value of the http_aut parameter of the configuration file (config_file.yml) was not being set correctly. The configuration I have set is http_auth: $ {ELASTIC_CREDENTIAL}, being ELASTIC_CREDENTIAL an environment variable that was passed in the docker-compose.

I would test with the elastic user to see if the "Error:‘ tuple ’object is not callable" is due to it. If it works, I would look at the permissions configuration with certificate, which by the description of the error is what you use.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.