Error while using elastic search while creating a osgi bundle


(Sidharthan) #1

created a wrapper for elastic search. it working fine while running as java
application. But while i create OSGI bundle it throwing a error.

Errror:
org.elasticsearch.env.FailedToResolveConfigException: Failed to resolve
config path [names.txt], tried file path [names.txt], path file
[/home/local/user/sidharthan.r/config/names.txt], and classpath
at org.elasticsearch.env.Environment.resolveConfig(Environment.java:207)
at
org.elasticsearch.node.internal.InternalSettingsPreparer.prepareSettings(InternalSettingsPreparer.java:118)
at
org.elasticsearch.client.transport.TransportClient.(TransportClient.java:154)
at
org.elasticsearch.client.transport.TransportClient.(TransportClient.java:120)
at
com.payoda.commons.elasticsearch.util.GenericEsSearch.getES(GenericEsSearch.java:54)

if i copy names.txt file from elasticsearch.jar to path [/home/local/user/sidharthan.r/config/names.txt]
it working fine.. But how to change default path to custom path or how can
i point out the names.txt inside elasticsearch.jar/config/names.txt

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3ba0a3f7-6316-4f0a-9ea1-266cdab9f221%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #2

Hey,

i dont have an awful lot of osgi experience, but a valid workaround might
be to set the "node.name" setting by yourself, when initializing the
TransportClient, as this should prevent trying to load the names.txt file

--Alex

On Tue, Feb 4, 2014 at 6:15 AM, Gowtham Sidharth sidharthancrt@gmail.comwrote:

created a wrapper for elastic search. it working fine while running as
java application. But while i create OSGI bundle it throwing a error.

Errror:
org.elasticsearch.env.FailedToResolveConfigException: Failed to resolve
config path [names.txt], tried file path [names.txt], path file
[/home/local/user/sidharthan.r/config/names.txt], and classpath
at org.elasticsearch.env.Environment.resolveConfig(Environment.java:207)
at
org.elasticsearch.node.internal.InternalSettingsPreparer.prepareSettings(InternalSettingsPreparer.java:118)
at
org.elasticsearch.client.transport.TransportClient.(TransportClient.java:154)
at
org.elasticsearch.client.transport.TransportClient.(TransportClient.java:120)
at
com.payoda.commons.elasticsearch.util.GenericEsSearch.getES(GenericEsSearch.java:54)

if i copy names.txt file from elasticsearch.jar to path [/home/local/user/sidharthan.r/config/names.txt]
it working fine.. But how to change default path to custom path or how can
i point out the names.txt inside elasticsearch.jar/config/names.txt

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3ba0a3f7-6316-4f0a-9ea1-266cdab9f221%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM-b0vvWj0OiFF%2BoQV4b9W_1xk5Xh4fhAKRuXxXNpE2Csg%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Sidharthan) #3

If i create one node means it easy to mention name to node. But, In multi
node Environment, i need to create more than one node. That time i cant
mention node name to TransportClient each time. Please Suggest me some
thing else.

Many Thanks,
Sidharthan C R

On Thu, Feb 6, 2014 at 3:40 PM, Alexander Reelsen alr@spinscale.de wrote:

Hey,

i dont have an awful lot of osgi experience, but a valid workaround might
be to set the "node.name" setting by yourself, when initializing the
TransportClient, as this should prevent trying to load the names.txt file

--Alex

On Tue, Feb 4, 2014 at 6:15 AM, Gowtham Sidharth sidharthancrt@gmail.comwrote:

created a wrapper for elastic search. it working fine while running as
java application. But while i create OSGI bundle it throwing a error.

Errror:
org.elasticsearch.env.FailedToResolveConfigException: Failed to resolve
config path [names.txt], tried file path [names.txt], path file
[/home/local/user/sidharthan.r/config/names.txt], and classpath
at org.elasticsearch.env.Environment.resolveConfig(Environment.java:207)
at
org.elasticsearch.node.internal.InternalSettingsPreparer.prepareSettings(InternalSettingsPreparer.java:118)
at
org.elasticsearch.client.transport.TransportClient.(TransportClient.java:154)
at
org.elasticsearch.client.transport.TransportClient.(TransportClient.java:120)
at
com.payoda.commons.elasticsearch.util.GenericEsSearch.getES(GenericEsSearch.java:54)

if i copy names.txt file from elasticsearch.jar to path [/home/local/user/sidharthan.r/config/names.txt]
it working fine.. But how to change default path to custom path or how can
i point out the names.txt inside elasticsearch.jar/config/names.txt

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3ba0a3f7-6316-4f0a-9ea1-266cdab9f221%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/pVECqHOr9Gc/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAGCwEM-b0vvWj0OiFF%2BoQV4b9W_1xk5Xh4fhAKRuXxXNpE2Csg%40mail.gmail.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALJ_DUgwpmFsF_sD_E%3D%2BmiwGVx2TPTTiC1iVD9CrUr5j_bs8ig%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4