ES 1.4.2 - MasterNotDiscovered Exception with Java Node Client

I am trying to connect with a Java application from localhost to my
elasticsearch cluster on a root server. My problem is that the java client
is not able to get a connection.

Ports 9200-9299 and 9300-9400 are opened on the root server(groupelite.de).

I configured my elasticsearch cluster to use unicast discovery and set its
inet ip address as "network.host".
This is how I instantiate my client:

NodeBuilder.nodeBuilder()
  .clusterName("neeedo-es")
  .settings(ImmutableSettings.settingsBuilder()
    .classLoader(classOf[Settings].getClassLoader)
    .put("discovery.zen.ping.unicast.hosts", "groupelite.de:9300")
    .put("node.name", "neeedo-client"))
  .client(true)
  .data(false)
  .node()

And this is my elasticsearch.yml

The firewall on the server should be turned off. You can also reach es with
http:
http://www.groupelite.de:9200/

The server is running ubuntu 14.04. Elasticsearch version is 1.4.2 on
client and server.

Iam not very used to networking stuff but I hope to get some ideas from you
guys what is wrong.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/938933de-6f67-4dd3-ab93-8f42863b3ff9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

DO NOT leave your cluster open to anyone on the internet, this is a REALLY
BAD idea!!

On 1 February 2015 at 06:26, Stefan Meiwald st.meiwald@gmail.com wrote:

I am trying to connect with a Java application from localhost to my
elasticsearch cluster on a root server. My problem is that the java client
is not able to get a connection.

Ports 9200-9299 and 9300-9400 are opened on the root server(groupelite.de
).

I configured my elasticsearch cluster to use unicast discovery and set its
inet ip address as "network.host".
This is how I instantiate my client:

NodeBuilder.nodeBuilder()
  .clusterName("neeedo-es")
  .settings(ImmutableSettings.settingsBuilder()
    .classLoader(classOf[Settings].getClassLoader)
    .put("discovery.zen.ping.unicast.hosts", "groupelite.de:9300")
    .put("node.name", "neeedo-client"))
  .client(true)
  .data(false)
  .node()

And this is my elasticsearch.yml
https://gist.github.com/MeiSign/ccfdcc62643c1185bab3

The firewall on the server should be turned off. You can also reach es
with http:
http://www.groupelite.de:9200/

The server is running ubuntu 14.04. Elasticsearch version is 1.4.2 on
client and server.

Iam not very used to networking stuff but I hope to get some ideas from
you guys what is wrong.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/938933de-6f67-4dd3-ab93-8f42863b3ff9%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/938933de-6f67-4dd3-ab93-8f42863b3ff9%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-203b9qT2JQCo8kES6h%2BNrbj2JF6Zx1nS0QLm4OUUw7g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

There is no data on it right now and also only limited diskspace for es. I
am planning to tryout Shield and will secure it later on. But first of all
I want to be able to get a connection to it. :-/
Anyways thanks for your advice.

Am Sonntag, 1. Februar 2015 00:09:42 UTC+1 schrieb Mark Walkom:

DO NOT leave your cluster open to anyone on the internet, this is a REALLY
BAD idea!!

On 1 February 2015 at 06:26, Stefan Meiwald <st.me...@gmail.com
<javascript:>> wrote:

I am trying to connect with a Java application from localhost to my
elasticsearch cluster on a root server. My problem is that the java client
is not able to get a connection.

Ports 9200-9299 and 9300-9400 are opened on the root server(groupelite.de
).

I configured my elasticsearch cluster to use unicast discovery and set
its inet ip address as "network.host".
This is how I instantiate my client:

NodeBuilder.nodeBuilder()
  .clusterName("neeedo-es")
  .settings(ImmutableSettings.settingsBuilder()
    .classLoader(classOf[Settings].getClassLoader)
    .put("discovery.zen.ping.unicast.hosts", "groupelite.de:9300")
    .put("node.name", "neeedo-client"))
  .client(true)
  .data(false)
  .node()

And this is my elasticsearch.yml
https://gist.github.com/MeiSign/ccfdcc62643c1185bab3

The firewall on the server should be turned off. You can also reach es
with http:
http://www.groupelite.de:9200/

The server is running ubuntu 14.04. Elasticsearch version is 1.4.2 on
client and server.

Iam not very used to networking stuff but I hope to get some ideas from
you guys what is wrong.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/938933de-6f67-4dd3-ab93-8f42863b3ff9%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/938933de-6f67-4dd3-ab93-8f42863b3ff9%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ef605be0-adfb-4401-ad85-918c5d660ec0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I have found out, that it works when I use a Transport Client. Does this
give any hint what is wrong with the Node Client Configuration? Both
clients are using the elasticsearch binary protocol and port 9300 right?

Am Samstag, 31. Januar 2015 20:26:25 UTC+1 schrieb Stefan Meiwald:

I am trying to connect with a Java application from localhost to my
elasticsearch cluster on a root server. My problem is that the java client
is not able to get a connection.

Ports 9200-9299 and 9300-9400 are opened on the root server(groupelite.de
).

I configured my elasticsearch cluster to use unicast discovery and set its
inet ip address as "network.host".
This is how I instantiate my client:

NodeBuilder.nodeBuilder()
  .clusterName("neeedo-es")
  .settings(ImmutableSettings.settingsBuilder()
    .classLoader(classOf[Settings].getClassLoader)
    .put("discovery.zen.ping.unicast.hosts", "groupelite.de:9300")
    .put("node.name", "neeedo-client"))
  .client(true)
  .data(false)
  .node()

And this is my elasticsearch.yml
https://gist.github.com/MeiSign/ccfdcc62643c1185bab3

The firewall on the server should be turned off. You can also reach es
with http:
http://www.groupelite.de:9200/

The server is running ubuntu 14.04. Elasticsearch version is 1.4.2 on
client and server.

Iam not very used to networking stuff but I hope to get some ideas from
you guys what is wrong.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d5681c2c-6a34-437b-b9ac-c0074435c64a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.