ES and AWS Cloud plugin autodiscovery not working


(Nicolas G) #1

Hi,

I'm trying to make the AWS auto-discovery plugin between 2 nodes to work
with no luck , each node is only aware of itself and set as a master.

This is regarding ELASTICSEARCH_VERSION : "1.1.1" and
ES_AWS_CLOUD_PLUGIN_VERSION: "2.1.1" .

See my configuration file bellow :

/etc/elasticsearch/elasticsearch.yml :

"""
cluster.name: logstash

cloud:
aws:
access_key: WLFLIEJWLKJ23FKDJ983242H
secret_key: idl34dijfdi!fkvui3lkj2l3ifdslkjdf
discovery:
type: ec2
ec2:
groups: Elasticsearch

cloud:
aws:
region: us-east-1

node.name: es1.example.com
index.number_of_shards: 3
index.number_of_replicas: 1
path.data: /mnt/var/lib/elasticsearch/
bootstrap.mlockall: true
"""

/var/log/elasticsearch/logstash.log :

"""
[2014-05-19 19:11:50,839][WARN ][common.jna ] Unknown
mlockall error 0
[2014-05-19 19:11:50,947][INFO ][node ]
[es1. example.com] version[1.1.1], pid[11417],
build[f1585f0/2014-04-16T14:27:12Z]
[2014-05-19 19:11:50,947][INFO ][node ]
[es1. example.com] initializing ...
[2014-05-19 19:11:50,970][INFO ][plugins ]
[es1. example.com] loaded [cloud-aws], sites [bigdesk, paramedic, head,
kopf, HQ, inquisitor]
[2014-05-19 19:11:54,361][INFO ][node ]
[es1. example.com] initialized
[2014-05-19 19:11:54,361][INFO ][node ]
[es1. example.com] starting ...
[2014-05-19 19:11:54,442][INFO ][transport ]
[es1. example.com] bound_address {inet[/0:0:0:0:0:0:0:0:9300]},
publish_address {inet[/10.146.242.57:9300]}
[2014-05-19 19:11:58,170][INFO ][cluster.service ]
[es1. example.com] new_master
[es1. example.com][Xa1cVbphSAOwbv5Fm0MgoA][es1. example.com][inet[/10.146.242.57:9300]],
reason: zen-disco-join (elected_as_master)
[2014-05-19 19:11:58,199][INFO ][discovery ]
[es1. example.com] logstash/Xa1cVbphSAOwbv5Fm0MgoA
[2014-05-19 19:11:58,215][INFO ][http ]
[es1. example.com] bound_address {inet[/0:0:0:0:0:0:0:0:9200]},
publish_address {inet[/10.146.242.57:9200]}
[2014-05-19 19:11:58,229][INFO ][gateway ]
[es1. example.com] recovered [0] indices into cluster_state
[2014-05-19 19:11:58,229][INFO ][node ]
[es1. example.com] started
"""

Can some one help me please ???

Kind regards,
N.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/75f57b02-7561-47da-b5d7-4e8e78e75fb9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

What do you get if you set discovery to TRACE in logging.yml file?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 mai 2014 à 21:29, Nicolas G nicolasg@gmail.com a écrit :

Hi,

I'm trying to make the AWS auto-discovery plugin between 2 nodes to work with no luck , each node is only aware of itself and set as a master.

This is regarding ELASTICSEARCH_VERSION : "1.1.1" and ES_AWS_CLOUD_PLUGIN_VERSION: "2.1.1" .

See my configuration file bellow :

/etc/elasticsearch/elasticsearch.yml :

"""
cluster.name: logstash

cloud:
aws:
access_key: WLFLIEJWLKJ23FKDJ983242H
secret_key: idl34dijfdi!fkvui3lkj2l3ifdslkjdf
discovery:
type: ec2
ec2:
groups: Elasticsearch

cloud:
aws:
region: us-east-1

node.name: es1.example.com
index.number_of_shards: 3
index.number_of_replicas: 1
path.data: /mnt/var/lib/elasticsearch/
bootstrap.mlockall: true
"""

/var/log/elasticsearch/logstash.log :

"""
[2014-05-19 19:11:50,839][WARN ][common.jna ] Unknown mlockall error 0
[2014-05-19 19:11:50,947][INFO ][node ] [es1. example.com] version[1.1.1], pid[11417], build[f1585f0/2014-04-16T14:27:12Z]
[2014-05-19 19:11:50,947][INFO ][node ] [es1. example.com] initializing ...
[2014-05-19 19:11:50,970][INFO ][plugins ] [es1. example.com] loaded [cloud-aws], sites [bigdesk, paramedic, head, kopf, HQ, inquisitor]
[2014-05-19 19:11:54,361][INFO ][node ] [es1. example.com] initialized
[2014-05-19 19:11:54,361][INFO ][node ] [es1. example.com] starting ...
[2014-05-19 19:11:54,442][INFO ][transport ] [es1. example.com] bound_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish_address {inet[/10.146.242.57:9300]}
[2014-05-19 19:11:58,170][INFO ][cluster.service ] [es1. example.com] new_master [es1. example.com][Xa1cVbphSAOwbv5Fm0MgoA][es1. example.com][inet[/10.146.242.57:9300]], reason: zen-disco-join (elected_as_master)
[2014-05-19 19:11:58,199][INFO ][discovery ] [es1. example.com] logstash/Xa1cVbphSAOwbv5Fm0MgoA
[2014-05-19 19:11:58,215][INFO ][http ] [es1. example.com] bound_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/10.146.242.57:9200]}
[2014-05-19 19:11:58,229][INFO ][gateway ] [es1. example.com] recovered [0] indices into cluster_state
[2014-05-19 19:11:58,229][INFO ][node ] [es1. example.com] started
"""

Can some one help me please ???

Kind regards,
N.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/75f57b02-7561-47da-b5d7-4e8e78e75fb9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/C8DA99CD-0D19-4266-B8E6-6E3E3B772E14%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(Nicolas G) #3

Got it working, the IAM user didn't had the right discovery access policy.

Thanks !

On Monday, May 19, 2014 10:29:05 PM UTC+3, Nicolas G wrote:

Hi,

I'm trying to make the AWS auto-discovery plugin between 2 nodes to work
with no luck , each node is only aware of itself and set as a master.

This is regarding ELASTICSEARCH_VERSION : "1.1.1" and
ES_AWS_CLOUD_PLUGIN_VERSION: "2.1.1" .

See my configuration file bellow :

/etc/elasticsearch/elasticsearch.yml :

"""
cluster.name: logstash

cloud:
aws:
access_key: WLFLIEJWLKJ23FKDJ983242H
secret_key: idl34dijfdi!fkvui3lkj2l3ifdslkjdf
discovery:
type: ec2
ec2:
groups: Elasticsearch

cloud:
aws:
region: us-east-1

node.name: es1.example.com
index.number_of_shards: 3
index.number_of_replicas: 1
path.data: /mnt/var/lib/elasticsearch/
bootstrap.mlockall: true
"""

/var/log/elasticsearch/logstash.log :

"""
[2014-05-19 19:11:50,839][WARN ][common.jna ] Unknown
mlockall error 0
[2014-05-19 19:11:50,947][INFO ][node ] [es1.
example.com] version[1.1.1], pid[11417],
build[f1585f0/2014-04-16T14:27:12Z]
[2014-05-19 19:11:50,947][INFO ][node ] [es1.
example.com] initializing ...
[2014-05-19 19:11:50,970][INFO ][plugins ] [es1.
example.com] loaded [cloud-aws], sites [bigdesk, paramedic, head, kopf,
HQ, inquisitor]
[2014-05-19 19:11:54,361][INFO ][node ] [es1.
example.com] initialized
[2014-05-19 19:11:54,361][INFO ][node ] [es1.
example.com] starting ...
[2014-05-19 19:11:54,442][INFO ][transport ] [es1.
example.com] bound_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish_address
{inet[/10.146.242.57:9300]}
[2014-05-19 19:11:58,170][INFO ][cluster.service ] [es1.
example.com] new_master [es1. example.com][Xa1cVbphSAOwbv5Fm0MgoA][es1.
example.com][inet[/10.146.242.57:9300]], reason: zen-disco-join
(elected_as_master)
[2014-05-19 19:11:58,199][INFO ][discovery ] [es1.
example.com] logstash/Xa1cVbphSAOwbv5Fm0MgoA
[2014-05-19 19:11:58,215][INFO ][http ] [es1.
example.com] bound_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish_address
{inet[/10.146.242.57:9200]}
[2014-05-19 19:11:58,229][INFO ][gateway ] [es1.
example.com] recovered [0] indices into cluster_state
[2014-05-19 19:11:58,229][INFO ][node ] [es1.
example.com] started
"""

Can some one help me please ???

Kind regards,
N.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d237a5aa-dfe3-41b4-ad4d-d8e807216918%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4