ES hangs while indexing(very slow indexing)


(Mostafa Wattad) #1

Hi
I have an issue while indexing nested document(60-100MB) using python client.
I have the last elastic version.
The indexing is very slow and some times I got readTimeOut.
After the indexing process the whole index will hangs and searches will be slow as well, I tried to recreate the index but that doesn't help.
I have 5 machines in the cluster (without replicas), each machine with 32 GB RAM, i configured the memory heap size to be 16 GB and disabled the swapping.
I tried to use the hot_thread to see what is going on but I didn't see any thread with high CPU.

Indexing/updating/searching works nice with small documents before trying to index the big json (60-100MB) .

Does my mapping impact the indexing process?
Do I need to configure memory or something ?
What should I do ?

Thanks


(Jörg Prante) #2

Documents of such excessive size are definitely not working with standard settings, risk of OOM and stalled nodes is high.

Have you tried to increase indices memory buffer?

https://www.elastic.co/guide/en/elasticsearch/reference/2.2/indexing-buffer.html

Also, there is a 100mb limit on HTTP receive buffer which might be relevant

https://www.elastic.co/guide/en/elasticsearch/reference/2.2/modules-http.html


(system) #3