ES_HEAP_SIZE and node stats report don't match


(Vagif Abilov) #1

Hi,

In attempt to increase JVM heap size for Elasticsearch on a Windows box, I
defined the following environment variable:

ES_HEAP_SIZE=6g

(The machine has 12G RAM in total).

I have restarted ES and queried its memory usage using _nodes/stat HTTP GET
command. However, it seems that it's still using 1GB:

mem: {

  • heap_used_in_bytes: 1032367576,
  • heap_used_percent: 99,
  • heap_committed_in_bytes: 1037959168,
  • heap_max_in_bytes: 1037959168,
  • ...

Shouldn't ES adjust its heap memory size after the restart?

Thanks in advance

Vagif

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f927807a-dfae-419e-99d6-02db243f7052%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Vagif Abilov) #2

After I had uninstalled and reinstalled Elasticsearch Windows service, it
correctly increased the JVM heap size. Just restarting it without
reinstalling the service didn't work.

Vagif

On Tuesday, November 25, 2014 2:45:04 PM UTC+1, Vagif Abilov wrote:

Hi,

In attempt to increase JVM heap size for Elasticsearch on a Windows box, I
defined the following environment variable:

ES_HEAP_SIZE=6g

(The machine has 12G RAM in total).

I have restarted ES and queried its memory usage using _nodes/stat HTTP
GET command. However, it seems that it's still using 1GB:

mem: {

  • heap_used_in_bytes: 1032367576,
  • heap_used_percent: 99,
  • heap_committed_in_bytes: 1037959168,
  • heap_max_in_bytes: 1037959168,
  • ...

Shouldn't ES adjust its heap memory size after the restart?

Thanks in advance

Vagif

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/618bcc78-e708-47b3-a1b7-22ebf84c54b2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Heath Aldrich) #3

Did anyone else confirm this as an issue?
I see the exact same thing on my box, but really hate to uninstall the service if there is another way.


(Anh) #4

Yes, there is another way. On windows, go to ES bin folder and run

service manager

On one of the tabs of ES service properties, you can set min and max heap size. This is how you run multiple ES nodes with different heap size on the same machine.


(system) #5