ES indexing exactly half the documents


(None) #1

Using ES 1.1.1

I have 4 node cluster

1 primary 3 workers

Starting each node with Elasticsearc.bat (Uisng windows 2003, JAVA 1.7_45
and 16GB heap)

Using the index api to create the index automatically on the first POST
operation....

POST http://10.0.0.xxx:9200/xxx/abc/

POST data:
{
"account" : 12345678,
"started": "2014-05-26T15:30:14.910",
"ended": "2014-05-26T15:30:17.697"
}

Sending direct http using JMeter. I sent 5000 requests give or take, but
Marvel and Head show that only 2500 documents got indexed???

I'm I missing something is it a config thing?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/638d37a9-5060-4d3d-bc15-f62ec023b8dd%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(None) #2

Used PUT not POST. Also seems to be doing the same thing with the Java
client as embedded node.

No matter how many requests i send only half the docs get indexed.

On Monday, 26 May 2014 11:35:04 UTC-4, John Smith wrote:

Using ES 1.1.1

I have 4 node cluster

1 primary 3 workers

Starting each node with Elasticsearc.bat (Uisng windows 2003, JAVA 1.7_45
and 16GB heap)

Using the index api to create the index automatically on the first POST
operation....

POST http://10.0.0.xxx:9200/xxx/abc/

POST data:
{
"account" : 12345678,
"started": "2014-05-26T15:30:14.910",
"ended": "2014-05-26T15:30:17.697"
}

Sending direct http using JMeter. I sent 5000 requests give or take, but
Marvel and Head show that only 2500 documents got indexed???

I'm I missing something is it a config thing?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9bfbc6d4-8b46-4c60-b82c-0fcc0702f31b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(None) #3

Never mind complete clown here. That's me! :stuck_out_tongue:

I was looking at the Jmeter summary report where my test script has
multiple samplers (2 to be exact) and I was looking at the total and not
how many HTTP requests I sent. The numbers match lol! Never mind!

As you were!

On Monday, 26 May 2014 11:40:38 UTC-4, John Smith wrote:

Used PUT not POST. Also seems to be doing the same thing with the Java
client as embedded node.

No matter how many requests i send only half the docs get indexed.

On Monday, 26 May 2014 11:35:04 UTC-4, John Smith wrote:

Using ES 1.1.1

I have 4 node cluster

1 primary 3 workers

Starting each node with Elasticsearc.bat (Uisng windows 2003, JAVA 1.7_45
and 16GB heap)

Using the index api to create the index automatically on the first POST
operation....

POST http://10.0.0.xxx:9200/xxx/abc/

POST data:
{
"account" : 12345678,
"started": "2014-05-26T15:30:14.910",
"ended": "2014-05-26T15:30:17.697"
}

Sending direct http using JMeter. I sent 5000 requests give or take, but
Marvel and Head show that only 2500 documents got indexed???

I'm I missing something is it a config thing?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9291ad06-78f0-48cc-9cc9-5295a81e8afb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4