Es spark ignoring fields query parameter


(Israel Klein) #1

Hi,

I am using es-spark_2.11-2.1.0.Beta4 on Spark 1.3.1 shell against
elasticsearch 1.4.4.

Doing:

import org.elasticsearch.spark._

val esRdd = sc.esRDD("my_index/my_type?q=fields:field_name")

esRdd.take(1)

results in getting the whole document source and not just the specified
field.

Thanks for the help.

Israel

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d1e7fb54-bf2c-4a8a-a65c-e8d20cd58337%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Costin Leau) #2

To specify the query, use es.query param or the second string param in
esRDD. The doc provide detailed information.

In a future version, we'll throw an exception if a query is specified in
the index.
On Apr 30, 2015 5:03 PM, "Israel Klein" israel.klein@gmail.com wrote:

Hi,

I am using es-spark_2.11-2.1.0.Beta4 on Spark 1.3.1 shell against
elasticsearch 1.4.4.

Doing:

import org.elasticsearch.spark._

val esRdd = sc.esRDD("my_index/my_type?q=fields:field_name")

esRdd.take(1)

results in getting the whole document source and not just the specified
field.

Thanks for the help.

Israel

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d1e7fb54-bf2c-4a8a-a65c-e8d20cd58337%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/d1e7fb54-bf2c-4a8a-a65c-e8d20cd58337%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAJogdmdaDcU%3DkNY6XxH%2BHjZ%2BUs7QXjBv326HeQhCp9PExZW-0Q%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Israel Klein) #3

Hi Costin,

It was my mistake in the question. First I have tried the above and it did
not work at all(obviously) but then I have tried
val esRdd = sc.esRDD("my_index/my_type"," ?fields=field_name") as well with
the mentioned above result.

On Thursday, April 30, 2015 at 5:47:15 PM UTC+3, Costin Leau wrote:

To specify the query, use es.query param or the second string param in
esRDD. The doc provide detailed information.

In a future version, we'll throw an exception if a query is specified in
the index.
On Apr 30, 2015 5:03 PM, "Israel Klein" <israel...@gmail.com <javascript:>>
wrote:

Hi,

I am using es-spark_2.11-2.1.0.Beta4 on Spark 1.3.1 shell against
elasticsearch 1.4.4.

Doing:

import org.elasticsearch.spark._

val esRdd = sc.esRDD("my_index/my_type?q=fields:field_name")

esRdd.take(1)

results in getting the whole document source and not just the specified
field.

Thanks for the help.

Israel

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d1e7fb54-bf2c-4a8a-a65c-e8d20cd58337%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/d1e7fb54-bf2c-4a8a-a65c-e8d20cd58337%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6e87a23a-dd16-4a62-901b-87514c568269%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Costin Leau) #4

Please raise an issue (more info about what's needed can be found here [1]).

Cheers,

[1] http://www.elastic.co/guide/en/elasticsearch/hadoop/master/troubleshooting.html#help

On Thu, Apr 30, 2015 at 6:28 PM, Israel Klein israel.klein@gmail.com wrote:

Hi Costin,

It was my mistake in the question. First I have tried the above and it did
not work at all(obviously) but then I have tried
val esRdd = sc.esRDD("my_index/my_type"," ?fields=field_name") as well with
the mentioned above result.

On Thursday, April 30, 2015 at 5:47:15 PM UTC+3, Costin Leau wrote:

To specify the query, use es.query param or the second string param in
esRDD. The doc provide detailed information.

In a future version, we'll throw an exception if a query is specified in
the index.

On Apr 30, 2015 5:03 PM, "Israel Klein" israel...@gmail.com wrote:

Hi,

I am using es-spark_2.11-2.1.0.Beta4 on Spark 1.3.1 shell against
elasticsearch 1.4.4.

Doing:

import org.elasticsearch.spark._

val esRdd = sc.esRDD("my_index/my_type?q=fields:field_name")

esRdd.take(1)

results in getting the whole document source and not just the specified
field.

Thanks for the help.

Israel

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d1e7fb54-bf2c-4a8a-a65c-e8d20cd58337%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6e87a23a-dd16-4a62-901b-87514c568269%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAJogdmeWs5jDn1HDO2sBJMSmZftes3QxjSFszcs54CZ_D1%2BQLg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #5