ES - xpack & https

Hello folks,

Once again I am turning to you.

My SSL/TLS works. However when I add my HTTPS, it fails. I have added my certificate password with the command from the link below. I use the same cert for my TLS & HTTPS.

Error from journalctl or status doesn't say much except that elasticsearch is failing.

Any insight ?


  • Removing password from keystore and re-adding them.

Config true true true certs/master1.p12 certs/master1.p12 certs/master1.p12 certs/master1.p12

So... for some reason I cannot explain, the certificate password got removed. It was an empty string. I had to change all my secure keys to match up.

How did I found out ?

  1. Exported the certificate on a desktop.
  2. Tried to install the certificate with the password entered at creation.
  3. It didn't work so I tried an empty string and it was successful.

If that can be any help to someone out there.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.