ESHadoop Port


(Abhijitdeka11) #1

Hi,

I am working on a monitored environment where I need to explicitly open ports that are needed to be opened.
I was trying the ESHadoop plugin to store data in ElasticSearch via Pig script.I am storing this as

STORE test INTO 'ESHadoop/test' USING org.elasticsearch.hadoop.pig.EsStorage('es.nodes=10.42.200.155','es.http.timeout = 5m','es.index.auto.create = true','es.mapping.id=ID');

But it doesn't seem to work.It doesn't throw any error but the pig script keeps running.Do I need to open ports in the Hadoop cluster.ES and Hadoop servers are on different machine.


(Costin Leau) #2

There might be multiple reasons why the script does not work and only the Pig logs will provide useful information.
If you want to specify the ES port then you can do so through the es.port property. This is documented under the configuration section in the reference documentation.


(Abhijitdeka11) #3

Hey I got this working.
The script was not able to identify the nodes because of virtual IP settings.
Now it's fine.
Thanks for replying.


(system) #4