/etc/rc.d/init.d/filebeat for pfSense - freeBSD 13

Hi, I just install filebeat v6.8.7 on my pfSense 2.4.5 box. But when I start with command
service filebeat start
it throws the error

start does not exist in /etc/rc.d or the local startup
directories (/usr/local/etc/rc.d), or is not executable

Can anyone provide me the startup file for filebeat on freeBSD?
Or how to install the lastest version v7.6.0 on freeBSD?
I tried the instruction: https://blog.securitybits.io/2019/12/beats-7.5.0-on-pfsense-2.4.4/
but got error:

# cd filebeat/
# gmake
go build -ldflags "-X github.com/elastic/beats/libbeat/version.buildTime=2020-05-18T08:05:30Z -X github.com/elastic/beats/libbeat/version.commit=6a23e8f8f30f5001ba344e                                        4e54d8d9cb82cb107c"
# github.com/elastic/beats/vendor/github.com/DataDog/zstd
exec: "clang": executable file not found in $PATH
# github.com/elastic/beats/vendor/github.com/elastic/gosigar
exec: "clang": executable file not found in $PATH
gmake: *** [../libbeat/scripts/Makefile:121: filebeat] Error 2

Thanks a lots

This looks like a configuration issue on the machine. Did you try to start the binary manually (not as a service)?

Hi, I cant find the binary. The directory system is difference to linux
Do you suggest me the location, please?

Hi, I tried to find but can't see. Check the module and v6.8.7 doesnt have zeek log module so I delete it.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.