Exact name match search - can't get it to work

https://gist.github.com/anonymous/b59ea5a6bbf308f8e562

This is the definition of the problem.
It seems that "index" : "not_analyzed" is broken when using copy_to fields

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ddd7c884-788d-4f92-a338-d193f5ed2948%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

The terms are copied to the full name and are not analyzed as specified.
However, two terms are being copied, not one. The term query expects a
single token of "Jeremy Smith", while you have two separate non analyzed
tokens.

Cheers,

Ivan
On Nov 12, 2014 10:29 AM, "Robert Alkire" dracomorbis@gmail.com wrote:

https://gist.github.com/anonymous/b59ea5a6bbf308f8e562

This is the definition of the problem.
It seems that "index" : "not_analyzed" is broken when using copy_to fields

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ddd7c884-788d-4f92-a338-d193f5ed2948%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/ddd7c884-788d-4f92-a338-d193f5ed2948%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQDd%2BDiYy3zrQsyjZNQn09FY-E0o-np7FAtWnaTJ%2BPXcJw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Ignore first link use this instead:
https://gist.github.com/anonymous/7051eb01114d4cbf3160
I understand the composite now is composed of two tokens thus my query must
be altered. If there is a better way to accomplish what I desire to do,
please let me know.

On Wednesday, November 12, 2014 9:26:48 AM UTC-6, Robert Alkire wrote:

https://gist.github.com/anonymous/b59ea5a6bbf308f8e562

This is the definition of the problem.
It seems that "index" : "not_analyzed" is broken when using copy_to fields

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b2ec8f58-b4cf-4180-a91d-dbee64f6682d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.