Facet_filter for boolean field does not work in TermsFacetBuilder


(Chetana) #1

I have a boolean field 'flag' which I want to filter for facet field
'sub_type'. But the total count is zero though there are some documents
satisfying the criteria.
But if I apply facet-filter on any other field (non-boolean) I get the
results. Is there any work around for this?

Json of Facet looks like :

"facets" : {
"sub-type" : {
"terms" : {
"field" : "sub-type",
"size" : 10
},
"facet_filter" : {
"term" : {
"flag" : true
}
},
"global" : true
}
}

Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/38fc93df-d984-4d2c-a754-2c785088d86c%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ivan Brusic) #2

Is the sub-type field analyzed?

--

Ivan
On Dec 27, 2013 1:20 AM, "Chetana" ambha.career@gmail.com wrote:

I have a boolean field 'flag' which I want to filter for facet field
'sub_type'. But the total count is zero though there are some documents
satisfying the criteria.
But if I apply facet-filter on any other field (non-boolean) I get the
results. Is there any work around for this?

Json of Facet looks like :

"facets" : {
"sub-type" : {
"terms" : {
"field" : "sub-type",
"size" : 10
},
"facet_filter" : {
"term" : {
"flag" : true
}
},
"global" : true
}
}

Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/38fc93df-d984-4d2c-a754-2c785088d86c%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQAcqQ%3DDBOc_JcXXJ52kktX23%2BocoUcp1xX4hcP-QB62Pw%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3