Facing connection refused issue while starting metricbeat

Hi ,

I have installed elk stack on some server A with IP: x.x.x.x.
I have installed metricbeat on another server B with IP: y.y.y.y

I have configured metricbeat.yml as below

####### Metricbeat Configuration Example

This file is an example configuration file highlighting only the most common

options. The metricbeat.reference.yml file from the same directory contains all the

supported options with more comments. You can use it as a reference.

You can find the full configuration reference here:


=========== Modules configuration ==========

Glob pattern for configuration loading

path: ${path.config}/modules.d/*.yml

Set to true to enable config reloading

reload.enabled: false

Period on which files under path should be checked for changes

#reload.period: 10s
========== Elasticsearch template setting =========

index.number_of_shards: 1
index.codec: best_compression
#_source.enabled: false

====================== General ========

The name of the shipper that publishes the network data. It can be used to group

all the transactions sent by a single shipper in the web interface.


The tags of the shipper are included in their own field with each

transaction published.

#tags: ["service-X", "web-tier"]

Optional fields that you can specify to add additional information to the



env: staging

======================= Dashboards ============

These settings control loading the sample dashboards to the Kibana index. Loading

the dashboards is disabled by default and can be enabled either by setting the

options here, or by using the -setup CLI flag or the setup command.

#setup.dashboards.enabled: false

The URL from where to download the dashboards archive. By default this URL

has a value which is computed based on the Beat name and version. For released

versions, this URL points to the dashboard archive on the artifacts.elastic.co



============ Kibana ============

Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.

This requires a Kibana endpoint configuration.

host: "x.x.x.x:5601"

Kibana Host

Scheme and port can be left out and will be set to the default (http and 5601)

In case you specify and additional path, the scheme is required: http://localhost:5601/path

IPv6 addresses should always be defined as: https://[2001:db8::1]:5601

#host: ["ip-10-228-3-241.ec2.internal:5601"]

Kibana Space ID

ID of the Kibana Space into which the dashboards should be loaded. By default,

the Default Space will be used.


============== Elastic Cloud ============

These settings simplify using metricbeat with the Elastic Cloud (https://cloud.elastic.co/).

The cloud.id setting overwrites the output.elasticsearch.hosts and

setup.kibana.host options.

You can find the cloud.id in the Elastic Cloud web UI.


The cloud.auth setting overwrites the output.elasticsearch.username and

output.elasticsearch.password settings. The format is <user>:<pass>.


#================================ Outputs =====================================

Configure what output to use when sending the data collected by the beat.

#-------------------------- Elasticsearch output ------------------------------

Array of hosts to connect to.

#hosts: "x.x.x.x:9300"

Enabled ilm (beta) to use index lifecycle management instead daily indices.

#ilm.enabled: false

Optional protocol and basic auth credentials.

#protocol: "https"
#username: "elastic"
#password: "changeme"

#----------------------------- Logstash output --------------------------------

The Logstash hosts

hosts: "x.x.x.x:5044"

Optional SSL. By default is off.

List of root certificates for HTTPS server verifications

#ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]

Certificate for SSL client authentication

#ssl.certificate: "/etc/pki/client/cert.pem"

Client Certificate Key

#ssl.key: "/etc/pki/client/cert.key"

#================================ Processors =====================================

Configure processors to enhance or manipulate events generated by the beat.


  • add_host_metadata: ~
  • add_cloud_metadata: ~

================= Logging ==============

Sets log level. The default log level is info.

Available log levels are: error, warning, info, debug

#logging.level: debug

At debug level, you can selectively enable logging only for some components.

To enable all selectors use ["*"]. Examples of other selectors are "beat",

"publish", "service".

#logging.selectors: ["*"]

#============================== Xpack Monitoring ===============================

metricbeat can export internal metrics to a central Elasticsearch monitoring

cluster. This requires xpack monitoring to be enabled in Elasticsearch. The

reporting is disabled by default.

Set to true to enable the monitoring reporter.

#xpack.monitoring.enabled: false

Uncomment to send the metrics to Elasticsearch. Most settings from the

Elasticsearch output are accepted here as well. Any setting that is not set is

automatically inherited from the Elasticsearch output configuration, so if you

have the Elasticsearch output configured, you can simply uncomment the

following line.


while I start the metricbeats service I got the below log.

2019-06-20T10:44:20.932-0400 ERROR pipeline/output.go:100 Failed to connect to backoff(async(tcp://x.x.x.x:5044)): dial tcp x.x.x.x:5044: i/o timeout
2019-06-20T10:44:20.932-0400 INFO pipeline/output.go:93 Attempting to reconnect to backoff(async(tcp:// with 13 reconnect attempt(s)
2019-06-20T10:44:20.933-0400 INFO [publish] pipeline/retry.go:189 retryer: send unwait-signal to consumer
2019-06-20T10:44:20.933-0400 INFO [publish] pipeline/retry.go:191 done
2019-06-20T10:44:20.933-0400 INFO [publish] pipeline/retry.go:166 retryer: send wait signal to consumer
2019-06-20T10:44:20.933-0400 INFO [publish] pipeline/retry.go:168 done
2019-06-20T10:44:29.747-0400 ERROR [kibana] elastic/elastic.go:107 error making http request: Get http://localhost:5601/api/status: dial tcp connect: connection refused
2019-06-20T10:44:39.747-0400 ERROR [kibana] elastic/elastic.go:107 error making http request: Get http://localhost:5601/api/status: dial tcp connect: connection refused
Please help me how to solve this issue.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.