Facing Issue - Elasticsearch Cluster Setting - 7.2


I have configured 5 node of elasticsearch 7.2.0
Now not able to connect them... They are not discovering them selves..

I have done following setting on each node configuration file.

discovery_hosts : [node1,node2,node3,node4,node5]
cluster_initial_master_nodes: [node1,node2,node3,node4,node5]

Please help me.

please take time to write up a proper report, including exact Elasticsearch version, log excerpts in a gist as well as configurations. See https://www.elastic.co/help

Thank you!

In both of these options you only need to provide the ip of those node which you want to make as master nodes so their is no need to provide all your 5 nodes ip here also delete all your logs stored in /var/log/elasticsearch and data in /var/lib/elasticsearch. Then do a fresh config .
Configure these options in your yml file:-

discovery.seed_hosts: ["master_node_ip" ]
cluster.initial_master_nodes: ["master_node_ip" ]
also provide a same cluster name across all nodes then you will be good to go.
at last restart your service and check the cluster state, goto https://master_node_ip:9200/_cluster/state

cluster.initial_master_nodes should normally be set to the node.name of the master node(s), not their IP address(es). It's technically possible to use either, but using the IP address(es) seems to cause a good deal of confusion so the node name is the recommended practice.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.