Fail to install logstash plugin, version 7.6.2

Hi, I just do everything like on
I did not change any code.
But It comes out some error when I try to install the plugin

./bin/logstash-plugin install --no-verify --local ./logstash-filter-java_filter_example-1.0.2.gem

ERROR: Something went wrong when installing ./logstash-filter-java_filter_example-1.0.2.gem, message: undefined method `headers' for #<Net::HTTPFound 302 Found readbody=true>

Hi, I'm facing the same error with multiple versions. All our scripts that worked till few days ago now are failing with this same error...

1 Like

Weird, same here just now. Did you manage to work around this issue?

Just to give more context, was able to add a non-custom plugin earlier after a few tries (elapsed plugin). Was having the same HTTPFound 302 error before the plugin was successfully installed. However, upon installing a custom local java filter plugin, using OP's same command, I can't install it anymore with the same HTTPFound 302 error.

im facing this error too

not yet.

I managed to make it work, updating rubygems (gem update --system, but I'm not sure that this was relevant) and removing './' from the path:

bin/logstash-plugin install --no-verify myplugin.gem

instead than

bin/logstash-plugin install --no-verify ./myplugin.gem

You can check if this works for you.


It works for me.
Thank you so much.

Wow removing './' actually worked. Didn't even have to do the gem update --system. Thank Alex!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.