Fail to put dynamic mapping after upgrading from 0.90.1. to 1.1.1


(deer) #1

Hi All,

In elasticsearch 0.90.1, we do the following :
curl -XPUT 'http://localhost:9200/testing/' -d '{
"settings" : {
"index" : {
"number_of_shards" : 1,
"number_of_replicas" : 0,
"refresh_interval" : "1m"
}
}
}'

curl -XPUT 'http://localhost:9200/testing/default/mapping?pretty=true' -d
'{
"default" : {
"dynamic_templates" : [
{
"multi_untouched_string_template" : {
"match" : "multi_untouched_string
*",
"mapping" : {
"type" : "multi_field",
"fields" : {
"{name}" : {"type": "{dynamic_type}",
"store" : "no", "include_in_all": "true"},
"{name}_untouched" : {"type": "{dynamic_type}",
"index" : "not_analyzed", "store" : "no", "include_in_all": "false"}

               }
           }
       }
     }                                                         
   ]
}        

}'

There is a dynamic templates add to the default mapping :
mappings: {
default: {
dynamic_templates: [ ... ],
properties: { .... }
}
}

However, we found that it is not working in elasticsearch 1.1.1. There is
no dynamic templates added to the default mapping :
mappings: {
default: {
properties: { ... }
}
}

And we found that the dynamic template is still supported after
elasticsearch 1.0.0.
ref
: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/mapping-root-object-type.html#_dynamic_templates

May I know is there any problem for my scripting? Many thanks.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/78cb07de-fd6a-4797-943a-bf9b0ab6b9fe%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2