Failed sending events! DOMException: The user aborted a request

I have APM and RUM configured as documentation says, and Vue in the frontend.

APM Server version: 8.8.1

This is my whole apm-server.yml:


    - elasticsearch:9200
  protocol: "https"
  username: "elastic"
  password: "my-pass"
  ssl.verification_mode: none
  enabled: true
  allow-origins: ["*"]
  allow-headers: ["*"]
  idle_timeout: 60s # added this by myself
apm-server.auth.anonymous.rate_limit.event_limit: 300
apm-server.auth.anonymous.rate_limit.ip_limit: 1000

RUM in Vue:
Screen Shot 2023-06-16 at 16.13.28

But in the browser I'm seeing this:

Just to add as much information as needed, the console warn points to a request from Vue.. but the request works correctly:

This is the same error from this topic here, I followed the suggestions but did not fixed.

There is a way to increase the idle time of RUM?
I tried this: apm-server.rum.idle_timeout: 60s, but as shown in the third image it still waiting just 10 seconds (just to make sure it is not related to resources)

And of course, any insight about this case will be helpful

Hi @Thiago_Medeiros,

Thanks for reaching out!


Let's try a few things:

  1. What does happen if you go to the Chrome console and execute: fetch(''). Is the request timing out as well?
  2. What does happen if you open a new tab with as the URL? What do you see?
  3. What do you see in the APM server logs?
  4. Question: Are you using the standalone APM server or the APM integration?


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.