Failed to send cluster state


(davrob) #1

Hi,

On version 16.1, I'm haveing this error:

[2011-05-27 07:03:02,624][DEBUG][discovery.zen.publish ] [Lila
Cheney] failed to send cluster state to [[Colossus]
[YIQOzlTzTwidgSoaOteHXQ][inet[/169.49.110.161:9301]]{client=true,
data=false}], should be detected as failed soon...

These are the details:

Error-Summary: https://gist.github.com/995654
Error-Full : https://gist.github.com/995655
Server Config : https://gist.github.com/995659
Client Config : https://gist.github.com/995671

Best Regards,

David


(davrob) #2

Thought I should also post the EOFExceptionthat appears to cause this:

[2011-05-27 12:33:38,488][INFO ][cluster.service ]
[Ghazikhanian, Carter] added {[Bloodwraith][gEJeYhpjQemmYQ2vvQZPVw]
[inet[/169.49.110.161:9301]]{client=true, data=false},}, reason: zen-
disco-receive(join from node[[Bloodwraith][gEJeYhpjQemmYQ2vvQZPVw]
[inet[/169.49.110.161:9301]]{client=true, data=false}])
[2011-05-27 12:33:38,679][DEBUG][discovery.zen.publish ]
[Ghazikhanian, Carter] failed to send cluster state to [[Bloodwraith]
[gEJeYhpjQemmYQ2vvQZPVw][inet[/169.49.110.161:9301]]{client=true,
data=false}], should be detected as failed soon...
org.elasticsearch.transport.RemoteTransportException: [Bloodwraith]
[inet[/169.49.110.161:9301]][discovery/zen/publish]
Caused by: java.io.EOFException
at
org.elasticsearch.common.io.stream.LZFStreamInput.readByte(LZFStreamInput.java:
123)
at
org.elasticsearch.common.io.stream.HandlesStreamInput.readByte(HandlesStreamInput.java:
80)
at
org.elasticsearch.common.io.stream.StreamInput.readInt(StreamInput.java:
64)
at
org.elasticsearch.common.io.stream.StreamInput.readLong(StreamInput.java:
95)
at org.elasticsearch.cluster.ClusterState
$Builder.readFrom(ClusterState.java:245)
at
org.elasticsearch.discovery.zen.publish.PublishClusterStateAction
$PublishClusterStateRequestHand

On May 27, 5:57 pm, davrob2 davirobe...@gmail.com wrote:

Hi,

On version 16.1, I'm haveing this error:

[2011-05-27 07:03:02,624][DEBUG][discovery.zen.publish ] [Lila
Cheney] failed to send cluster state to [[Colossus]
[YIQOzlTzTwidgSoaOteHXQ][inet[/169.49.110.161:9301]]{client=true,
data=false}], should be detected as failed soon...

These are the details:

Error-Summary:https://gist.github.com/995654
Error-Full : https://gist.github.com/995655
Server Config : https://gist.github.com/995659
Client Config : https://gist.github.com/995671

Best Regards,

David


(Shay Banon) #3

It seems like you are using one node with 0.15.2 version talking to a 0.16 node.

On Friday, May 27, 2011 at 9:52 PM, davrob2 wrote:

Thought I should also post the EOFExceptionthat appears to cause this:

[2011-05-27 12:33:38,488][INFO ][cluster.service ]
[Ghazikhanian, Carter] added {[Bloodwraith][gEJeYhpjQemmYQ2vvQZPVw]
[inet[/169.49.110.161:9301]]{client=true, data=false},}, reason: zen-
disco-receive(join from node[[Bloodwraith][gEJeYhpjQemmYQ2vvQZPVw]
[inet[/169.49.110.161:9301]]{client=true, data=false}])
[2011-05-27 12:33:38,679][DEBUG][discovery.zen.publish ]
[Ghazikhanian, Carter] failed to send cluster state to [[Bloodwraith]
[gEJeYhpjQemmYQ2vvQZPVw][inet[/169.49.110.161:9301]]{client=true,
data=false}], should be detected as failed soon...
org.elasticsearch.transport.RemoteTransportException: [Bloodwraith]
[inet[/169.49.110.161:9301]][discovery/zen/publish]
Caused by: java.io.EOFException
at
org.elasticsearch.common.io.stream.LZFStreamInput.readByte(LZFStreamInput.java:
123)
at
org.elasticsearch.common.io.stream.HandlesStreamInput.readByte(HandlesStreamInput.java:
80)
at
org.elasticsearch.common.io.stream.StreamInput.readInt(StreamInput.java:
64)
at
org.elasticsearch.common.io.stream.StreamInput.readLong(StreamInput.java:
95)
at org.elasticsearch.cluster.ClusterState
$Builder.readFrom(ClusterState.java:245)
at
org.elasticsearch.discovery.zen.publish.PublishClusterStateAction
$PublishClusterStateRequestHand

On May 27, 5:57 pm, davrob2 <davirobe...@gmail.com (http://gmail.com)> wrote:

Hi,

On version 16.1, I'm haveing this error:

[2011-05-27 07:03:02,624][DEBUG][discovery.zen.publish ] [Lila
Cheney] failed to send cluster state to [[Colossus]
[YIQOzlTzTwidgSoaOteHXQ][inet[/169.49.110.161:9301]]{client=true,
data=false}], should be detected as failed soon...

These are the details:

Error-Summary:https://gist.github.com/995654
Error-Full : https://gist.github.com/995655
Server Config : https://gist.github.com/995659
Client Config : https://gist.github.com/995671

Best Regards,

David


(davrob) #4

Great spot Shay, thanks! Our deployment process what messed up and
failing to delete previous jar files.

On May 28, 10:31 am, Shay Banon shay.ba...@elasticsearch.com wrote:

It seems like you are using one node with 0.15.2 version talking to a 0.16 node.

On Friday, May 27, 2011 at 9:52 PM, davrob2 wrote:

Thought I should also post the EOFExceptionthat appears to cause this:

[2011-05-27 12:33:38,488][INFO ][cluster.service ]
[Ghazikhanian, Carter] added {[Bloodwraith][gEJeYhpjQemmYQ2vvQZPVw]
[inet[/169.49.110.161:9301]]{client=true, data=false},}, reason: zen-
disco-receive(join from node[[Bloodwraith][gEJeYhpjQemmYQ2vvQZPVw]
[inet[/169.49.110.161:9301]]{client=true, data=false}])
[2011-05-27 12:33:38,679][DEBUG][discovery.zen.publish ]
[Ghazikhanian, Carter] failed to send cluster state to [[Bloodwraith]
[gEJeYhpjQemmYQ2vvQZPVw][inet[/169.49.110.161:9301]]{client=true,
data=false}], should be detected as failed soon...
org.elasticsearch.transport.RemoteTransportException: [Bloodwraith]
[inet[/169.49.110.161:9301]][discovery/zen/publish]
Caused by: java.io.EOFException
at
org.elasticsearch.common.io.stream.LZFStreamInput.readByte(LZFStreamInput.java:
123)
at
org.elasticsearch.common.io.stream.HandlesStreamInput.readByte(HandlesStreamInput.java:
80)
at
org.elasticsearch.common.io.stream.StreamInput.readInt(StreamInput.java:
64)
at
org.elasticsearch.common.io.stream.StreamInput.readLong(StreamInput.java:
95)
at org.elasticsearch.cluster.ClusterState
$Builder.readFrom(ClusterState.java:245)
at
org.elasticsearch.discovery.zen.publish.PublishClusterStateAction
$PublishClusterStateRequestHand

On May 27, 5:57 pm, davrob2 <davirobe...@gmail.com (http://gmail.com)> wrote:

Hi,

On version 16.1, I'm haveing this error:

[2011-05-27 07:03:02,624][DEBUG][discovery.zen.publish ] [Lila
Cheney] failed to send cluster state to [[Colossus]
[YIQOzlTzTwidgSoaOteHXQ][inet[/169.49.110.161:9301]]{client=true,
data=false}], should be detected as failed soon...

These are the details:

Error-Summary:https://gist.github.com/995654
Error-Full :https://gist.github.com/995655
Server Config :https://gist.github.com/995659
Client Config :https://gist.github.com/995671

Best Regards,

David


(fashionalwallet) #5
  • deleted -

(system) #6