Failed to send ping Ubuntu Cluster

I am trying to create an ElasticSearch cluster with 2 coordinating nodes and 3 master/data nodes.

I am seeing errors related to failed to send ping.
[2018-03-19T23:59:57,298][WARN ][o.e.d.z.UnicastZenPing ] [] failed to send ping to [{}{Aop3TF19TH2dp4gRiST92g}{9UCF2AT_Se2NhT6OmNnUIQ}{}{}]

This is occurring on every node in the cluster - and the ping destination failing covers all nodes in the cluster. I have explicitly set, transport.bind_host and in the /etc/elasticsearch/elasticsearch.yml file.

any recommendations on how to troubleshoot this? I can telnet to port 9300 on each server...

What version are you on, can you show us your config?

Mark -

I have solved my problem and here is what it turned out to be.

I am deploying in a Cisco UCS Openstack environment and nailing elastic search components up to an internal VLAN. The original VLAN I used is setup with MTU 9000 in the switching infrastructure. I moved it to a VLAN that uses 1500 MTU and everything worked.

1 Like

Very good to know. Thanks for sharing it.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.