Fantastic Elastic Plugin on WordPress - Hoe do you specify server authentication?


(Phil Long) #1

I set up my Elastic Server on on a dedicated digi Umuntu VM, separate from my web-site host service. Seem to work find for a while but but then I tightened the security up on the Elastic Server and now Elastic Search is failing with unable to login. Thing is I can't see where I set the user name/password in the first place. (I assume the Server field in General Setting is supposed to reference a remote elastic server?). What sort of authentication does it support - can I hack the plug0-in code to make is use an RSA Public key?


(Mark Walkom) #2

Natively, Elasticsearch doesn't support any auth. You need to install the Shield plugin to get this.


(system) #3