Fatal error enoent no such file or directory mkdtemp - KIBANA

when ever I run the batch file of Kibana (Elastic search is already running at the backend), I am getting the following error, please advise ASAP.

"Fatal Error: ENOCENT: no such file or directory, mkdtemp; \chromium-xxxxx"

Searched the discussion page, and found something as below:

  1. Some suggested to change the pid file path in the config file which has - pid.file: /var/run/kibana.pid, not sure what path i need to change
  2. Few suggested to download the chromium browser and run again

Above solutions didn't worked, so please advise ASAP

We could perhaps get further with this issue if we have a literal copy and paste of the error log message. Can you confirm this message was copied and pasted from your logs?

The correct spelling of the error is ENOENT as you have in the topic headline. It means a file that Kibana's scripting language, NodeJS, was told to open a file that doesn't exist.

In Kibana Reporting, the first time the server starts up, the system will look for a zip file in the Kibana install directory in:


The zip file has the Reporting headless browser program. Kibana Reporting plugin looks for a usable browser program in:


If that file doesn't exist in the Kibana install dir, which is the case the first time Kibana is ran (or if unzipping never happened successfully), the the Reporting plugin will try to unzip the program and install it into the data/headless_shell-[arch] directory.

It seems like an error is happening that makes the unzipping not work. Maybe you have the Kibana install dir in a readonly file system? Maybe there is a permissions issue? It would be more clear what the actual problem is if your error message was copied and pasted from the logs, with a few lines of context as well. The ENOCENT part was typed in - that's not an actual Windows OS error code.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.