Fielddata cache disabling when doc_values on


(no jihun) #1

hi all.

My ES cluster(5 nodes working) is now under memory pressure, full gc stop-the-world. so I have to do some tuning.
every document in ES are not analyzed and doc_values are enabled.

all of the search request called through kibana 4.
I know time ranged queries could be cached but usually can't be hit, because now timestamp moves.



[2015-09-22 17:12:34,647][WARN ][monitor.jvm ]
[node001] [gc][old][7495149][1292] duration [28.2s], collections [1]/[28.4s], total [28.2s]/[1.7h], memory [23.3gb]->[15.1gb]/[23.8gb], all_pools {[young] [1013.7mb]->[54.5mb]/[1.1gb]}{[survivor] [149.7mb]->[0b]/[149.7mb]}{[old] [22.1gb]->[15.1gb]/[22.5gb]}

[2015-09-22 17:17:02,305][WARN ][monitor.jvm ]
[node001] [gc][old][7495388][1296] duration [28.3s], collections [1]/[28.6s], total [28.3s]/[1.7h], memory [23gb]->[15.1gb]/[23.8gb], all_pools {[young] [912.2mb]->[76.5mb]/[1.1gb]}{[survivor] [149.7mb]->[0b]/[149.7mb]}{[old] [22gb]->[15gb]/[22.5gb]}

in that case can I turn the cache off?
some modification like this..

indices.fielddata.cache.size: 30%
indices.cache.filter.size: 10%
indices.cache.query.size: 10%
-->
indices.fielddata.cache.size: 1%
indices.cache.filter.size: 1%
indices.cache.query.size: 1%

ES reference doc says doc_values give a big advantage with memory pressure.
So I wonder why there are so much fielddata cache and fielddata eviction even I enabled doc_values to all data.

summary.

  1. fielddata cache needed even all doc_values enabled?
  2. kibana may cant hit the filter cache, query cache. turn cache 0% will help?
  3. any cache configure suggestion for large ES+ many kibana query.

Thanks.


(system) #2