File Descriptors


(kayngee) #1

Hi guys,

Kind of stuck with a fresh installation of an ElasticSearch cluster.
everything is installed file descriptor limits are set yet when I run

curl -XGET "http://10.0.8.62:9200/_nodes?os=true&process=true&pretty=true"

stats.txt

I get

  "process" : {
    "refresh_interval" : 1000,
    "id" : 1200,
    "max_file_descriptors" : 4096,
    "mlockall" : true
  },

yet when I run

ulimit -n I get

65535

ElasticSearch is installed as a service and running as root? Any idea why
this is happening?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/53e168b5-8834-4b63-98ec-4c5a3080a91b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

What OS and how did you install it?

(Running as root is a really bad idea by the way!)

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 22 May 2014 20:19, Shawn Ritchie xritchie@gmail.com wrote:

Hi guys,

Kind of stuck with a fresh installation of an ElasticSearch cluster.
everything is installed file descriptor limits are set yet when I run

curl -XGET "http://10.0.8.62:9200/_nodes?os=true&process=true&pretty=true"

stats.txt

I get

  "process" : {
    "refresh_interval" : 1000,
    "id" : 1200,
    "max_file_descriptors" : 4096,
    "mlockall" : true
  },

yet when I run

ulimit -n I get

65535

ElasticSearch is installed as a service and running as root? Any idea why
this is happening?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/53e168b5-8834-4b63-98ec-4c5a3080a91b%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/53e168b5-8834-4b63-98ec-4c5a3080a91b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624YGJTMJVwfZTea%3DJr4-K77hFvG6hYMoNfLWbTxBa3T4iw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(kayngee) #3

so this issue only occurs on server restart. If I had to restart
elasticsearch service it would load the correct number of file descriptors.

Regards
Shawn

On Thu, May 22, 2014 at 12:19 PM, Shawn Ritchie xritchie@gmail.com wrote:

Hi guys,

Kind of stuck with a fresh installation of an ElasticSearch cluster.
everything is installed file descriptor limits are set yet when I run

curl -XGET "http://10.0.8.62:9200/_nodes?os=true&process=true&pretty=true"

stats.txt

I get

  "process" : {
    "refresh_interval" : 1000,
    "id" : 1200,
    "max_file_descriptors" : 4096,
    "mlockall" : true
  },

yet when I run

ulimit -n I get

65535

ElasticSearch is installed as a service and running as root? Any idea why
this is happening?

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/SIKIWq40MKY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/53e168b5-8834-4b63-98ec-4c5a3080a91b%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/53e168b5-8834-4b63-98ec-4c5a3080a91b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Thanks
Shawn Ritchie

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAP0uL7zMEv-dDh1N1ZhY%3D2k9SPDt8bdiBPNqjn%2BPgYHqU0oRrQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(kayngee) #4

CentOS 6.5 and Java 1.7u55

On Thu, May 22, 2014 at 12:28 PM, Shawn Ritchie xritchie@gmail.com wrote:

so this issue only occurs on server restart. If I had to restart
elasticsearch service it would load the correct number of file descriptors.

Regards
Shawn

On Thu, May 22, 2014 at 12:19 PM, Shawn Ritchie xritchie@gmail.comwrote:

Hi guys,

Kind of stuck with a fresh installation of an ElasticSearch cluster.
everything is installed file descriptor limits are set yet when I run

curl -XGET "http://10.0.8.62:9200/_nodes?os=true&process=true&pretty=true"

stats.txt

I get

  "process" : {
    "refresh_interval" : 1000,
    "id" : 1200,
    "max_file_descriptors" : 4096,
    "mlockall" : true
  },

yet when I run

ulimit -n I get

65535

ElasticSearch is installed as a service and running as root? Any idea why
this is happening?

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/SIKIWq40MKY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/53e168b5-8834-4b63-98ec-4c5a3080a91b%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/53e168b5-8834-4b63-98ec-4c5a3080a91b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Thanks
Shawn Ritchie

--
Thanks
Shawn Ritchie

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAP0uL7xtHLT6%2ByjPMSENxQEZKYHJL_31ZuLW%2BUXNrO2GOJsSPw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #5

Did you use the RPMs? Where are you setting the ulimit?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 22 May 2014 20:30, Shawn Ritchie xritchie@gmail.com wrote:

CentOS 6.5 and Java 1.7u55

On Thu, May 22, 2014 at 12:28 PM, Shawn Ritchie xritchie@gmail.comwrote:

so this issue only occurs on server restart. If I had to restart
elasticsearch service it would load the correct number of file descriptors.

Regards
Shawn

On Thu, May 22, 2014 at 12:19 PM, Shawn Ritchie xritchie@gmail.comwrote:

Hi guys,

Kind of stuck with a fresh installation of an ElasticSearch cluster.
everything is installed file descriptor limits are set yet when I run

curl -XGET "
http://10.0.8.62:9200/_nodes?os=true&process=true&pretty=true" >
stats.txt

I get

  "process" : {
    "refresh_interval" : 1000,
    "id" : 1200,
    "max_file_descriptors" : 4096,
    "mlockall" : true
  },

yet when I run

ulimit -n I get

65535

ElasticSearch is installed as a service and running as root? Any idea
why this is happening?

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/SIKIWq40MKY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/53e168b5-8834-4b63-98ec-4c5a3080a91b%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/53e168b5-8834-4b63-98ec-4c5a3080a91b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Thanks
Shawn Ritchie

--
Thanks
Shawn Ritchie

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAP0uL7xtHLT6%2ByjPMSENxQEZKYHJL_31ZuLW%2BUXNrO2GOJsSPw%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAP0uL7xtHLT6%2ByjPMSENxQEZKYHJL_31ZuLW%2BUXNrO2GOJsSPw%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624bonFrf5V1eK%3D9Ug8SpSiC%3DWL3%3Dc6MRiOSmaK9Hkjz6KA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(kayngee) #6

No I did not use RPM used .tar for the installation process and my ulimit
settings are in

/etc/security/limits.conf

    • nofile 65535

/etc/sysctl.conf
fs.file-max = 512000

On Thu, May 22, 2014 at 12:37 PM, Mark Walkom markw@campaignmonitor.comwrote:

Did you use the RPMs? Where are you setting the ulimit?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 22 May 2014 20:30, Shawn Ritchie xritchie@gmail.com wrote:

CentOS 6.5 and Java 1.7u55

On Thu, May 22, 2014 at 12:28 PM, Shawn Ritchie xritchie@gmail.comwrote:

so this issue only occurs on server restart. If I had to restart
elasticsearch service it would load the correct number of file descriptors.

Regards
Shawn

On Thu, May 22, 2014 at 12:19 PM, Shawn Ritchie xritchie@gmail.comwrote:

Hi guys,

Kind of stuck with a fresh installation of an ElasticSearch cluster.
everything is installed file descriptor limits are set yet when I run

curl -XGET "
http://10.0.8.62:9200/_nodes?os=true&process=true&pretty=true" >
stats.txt

I get

  "process" : {
    "refresh_interval" : 1000,
    "id" : 1200,
    "max_file_descriptors" : 4096,
    "mlockall" : true
  },

yet when I run

ulimit -n I get

65535

ElasticSearch is installed as a service and running as root? Any idea
why this is happening?

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/SIKIWq40MKY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/53e168b5-8834-4b63-98ec-4c5a3080a91b%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/53e168b5-8834-4b63-98ec-4c5a3080a91b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Thanks
Shawn Ritchie

--
Thanks
Shawn Ritchie

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAP0uL7xtHLT6%2ByjPMSENxQEZKYHJL_31ZuLW%2BUXNrO2GOJsSPw%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAP0uL7xtHLT6%2ByjPMSENxQEZKYHJL_31ZuLW%2BUXNrO2GOJsSPw%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/SIKIWq40MKY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEM624bonFrf5V1eK%3D9Ug8SpSiC%3DWL3%3Dc6MRiOSmaK9Hkjz6KA%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAEM624bonFrf5V1eK%3D9Ug8SpSiC%3DWL3%3Dc6MRiOSmaK9Hkjz6KA%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Thanks
Shawn Ritchie

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAP0uL7zxoJe_W80wRU4Kqomv0MBzC67cwo8M%2B0WTmepvgs7CEg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #7