Filebeat 6.2.2 Cannot find nginx module

(Sami Jan) #1


I cannot load the nginx module in using /usr/share/filebeat/bin/filebeat

/usr/share/filebeat/bin/filebeat version
filebeat version 6.2.2 (amd64), libbeat 6.2.2

/etc/filebeat# /usr/share/filebeat/bin/filebeat modules enable nginx
Module nginx doesn't exists!

But this works:

/usr/bin/filebeat modules enable nginx
Enabled nginx

(Wanderer) #2

I've noticed the same problem on a fresh install when trying to enable the system module.

(ruflin) #3

I assume the problem is related to the paths which are set. How did you install filebeat?

(Sami Jan) #4

I used the repository guide, and used apt-get

(ruflin) #5

If you have a look at /usr/bin/filebeat you will see it sets all the correct paths:

#!/usr/bin/env bash

# Script to run filebeat in foreground with the same path settings that
# the init script / systemd unit file would do.

exec /usr/share/filebeat/bin/filebeat \
  -path.home /usr/share/filebeat \
  -path.config /etc/filebeat \ /var/lib/filebeat \
  -path.logs /var/log/filebeat \

So in case you want to call the binary directly, you also have to set paths manually as otherwise it falls back to the default paths which are relative to your current directory.

(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.