Filebeat 6.3.1 segmentation violation with go 1.11.1

Hi,

 We are using filebeat version 6.3.1 and go language version 1.11.1 crosscompiled for ARM freescal IMx6 Board. When we run the filebeat application, we are getting segmentation violation issue with go language 1.11.1

We are using filebeat version 6.3.1 and go language version 1.11.1 crosscompiled for ARM freescal IMx6 Board. When we run the filebeat application, we are getting segmentation violation issue with go language 1.11.1
Whereas when we use go 1.9.7, we are not seeing the issue.

Can anyone please suggest whether filebeat 6.3.1 is compatible with go 1.11.1
Any patches available to make it compatible and fix segmentaion issues

Regards
Abdul Moiz

Filebeat 6.3.1 is compatible with go 1.9.4. You can see this over here: https://github.com/elastic/beats/blob/6.3/.go-version.

Shaunak

Hi,

  Thanks for the reply. 

I tried by upgrading filebeat to version 7.0.2 and go lang to version 1.11.5 for compatibility, but still observing segmentation violation issue
I am using yocto sumo build for compiling filebeat and go language.
Can you please suggest

Regards
Abdul Moiz