Filebeat 6.x idle_timeout

Hi team:

I have recently upgraded to filebeat 6.3.2 from 5.3

Then I found the break changes: spooler is removed

so the config is not working anymore.

filebeat.idle_timeout: 2s

In our cluster, we collect the docker stdout log to realtime query from web shell. (the es refresh_interval is 1s)

After upgraded, I found the log sent to the es is delay for about 30s - 1min(compare to 5.3)

I read all the docs of 6.3.2, but did not find the config field like idle_timeout

How can I fix that?


Hi @wklken,

I think the replacement setting for filebeat.idle_timeout you are looking for is either queue.mem.flush.timeout or queue.spool.write.flush.timeout, depending on which queue type you are using (mem or spool).


It works.
Thank you @shaunak

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.