Filebeat 7.8 Azure module issue

Testing out the Azure module and leveraging the exact same configuration from a working 7.7 install generates the following error:

2020-06-18T23:19:14.508-0500	INFO	cfgfile/reload.go:224	Loading of config files completed.
2020-06-18T23:19:14.508-0500	INFO	[azure-eventhub input]	azureeventhub/input.go:107	azure-eventhub input worker has started.	{"connection string": "Endpoint=sb://;SharedAccessKeyName=azurefilebeat;SharedAccessKey=saskey..."}
2020-06-18T23:19:14.509-0500	ERROR	[azure-eventhub input]	azureeventhub/input.go:113	Get %3Cno%20value%3E/metadata/endpoints?api-version=1.0: unsupported protocol scheme ""	{"connection string": "Endpoint=sb://;SharedAccessKeyName=azurefilebeat;SharedAccessKey=saskey..."}
2020-06-18T23:19:14.509-0500	INFO	[azure-eventhub input]	azureeventhub/input.go:114	azure-eventhub input worker has stopped.	{"connection string": "Endpoint=sb://;SharedAccessKeyName=azurefilebeat;SharedAccessKey=saskey..."}

It doesn't look like the configuration options have changed at all, am I missing something or is this a bug?

I've just tried to set this up on 7.8 as well and ran into the same issue.

I'll file an issue on their github, wanted to make sure it wasn't just me.

Opened -

1 Like

@danielsnelling - the fix referenced in the github issue fixed it for me. Adding the following to each var block in azure.yml got it going

resource_manager_endpoint: ""

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.